Mls - Yamaha Rhino Forums - Yamaha UTV Forum

Yamaha Rhino Forums - Yamaha UTV Forum


Mls


This is a discussion on Mls within the Yamaha Rhino General Discussions forums, part of the The Garage category; I have a 2007 660 rhino,over the New year's in sub zero temps it started to act up with all
Go Back   Yamaha Rhino Forums - Yamaha UTV Forum > The Garage > Yamaha Rhino General Discussions


Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

Reply
 
LinkBack Thread Tools Display Modes
Old 01-11-2013, 12:21 PM   #1 (permalink)
mls
1/4 Throttle
 
Default Mls

I have a 2007 660 rhino,over the New year's in sub zero temps it started to act up with all the display lights staying on regardless of which gear you were in.Then it would not run past an idle unless you played with the choke and not well then. Any clues to what went wrong??
mls is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 09:49 AM.



Powered by vBulletin ®
Copyright © 2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
RhinoTalk.net is an independent Yamaha enthusiast website. Content on RhinoTalk.net is generated by its users and RhinoTalk.net is not in any way affiliated with Yamaha Motor Corporation, U.S.A.