help with sending unit install - Yamaha Rhino Forums - Yamaha UTV Forum
How-To's Database of technical articles to assist those do-it-yourselfers.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-04-2009, 03:30 PM Thread Starter
1/4 Throttle
 
Join Date: Dec 2008
Location: port orchard, wa
Posts: 5
help with sending unit install

I have installed digital Summit Racing gauges. The oil pressure sending unit is currently installed (and not leaking) in the drivers side oil cooling line. Is there any other location that will work better on my 08 450. The banjo bolts aren't on mine. Im getting 15-20 warm idle and 45-50 high speed no load. Thanks for the help as us old farts aren't used to anything smaller than a V8.
steveft is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-05-2009, 07:59 PM
No Longer Registered
 
Join Date: Jun 2008
Posts: 41
Sounds like you got it, these engines use difrent berring system than automotive and don't require as much oil pressure.

btw I see you are from Port Orchard Wa, I'm from Port Orford Or. you would be surprised how much of my stuff gets shipped there
oh well it's life here on the upper west coast.
Joe Llamahead is offline  
post #3 of 4 (permalink) Old 01-06-2009, 10:29 AM
Wide F'n Open
 
Join Date: Jun 2008
Posts: 121
I grew up in Port Orford OR! (sorry for the hijack)

I used the banjo bolt on my 660, but aparently the 450s dont have them. I think your getting good numbers, and its not leaking, so it should be good!
Wild Earp is offline  
 
post #4 of 4 (permalink) Old 01-06-2009, 10:38 AM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
Your all good!

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Install SXSCustms Other UTV Discussions 8 12-04-2008 07:43 AM
My new cage install JMS Yamaha Rhino General Discussions 21 10-24-2008 09:08 AM
Sub-Strap Install socalrider66 Yamaha Rhino Safety Discussions 5 10-05-2008 08:02 PM
New Head Unit SXSCustms Yamaha Rhino Electrical Discussions 5 09-02-2008 06:25 PM
Install Gallery Software? dieselpowered RhinoTalk Help Desk 10 07-02-2008 08:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57