New Clutch Install with problems - Yamaha Rhino Forums - Yamaha UTV Forum
How-To's Database of technical articles to assist those do-it-yourselfers.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-07-2010, 09:21 PM Thread Starter
1/4 Throttle
 
justinsoltis's Avatar
 
Join Date: Mar 2010
Location: Rock Springs Wy
Posts: 4
New Clutch Install with problems

I have a problem and dont know what it is and how to fix it, just wondering if any of you guys might have had the same problem. Okay I replaced my wet springs secondary and roller wieghts. Put it all back together and tried it now I have oil leaking into my clutch housing. I then took it all back apart cleaned it and tried it again thinking that I had the oil level too high, only because i couldn't see where the oil was leaking from. Same thing happened again. So i researched a parts list and the only oil that I could see was close to the clutch housing was the oil seal around the shaft of the primary clutch. So i replaced the seal and put a new gasket on the wet clutch case and tried it again and the samething happened so i am at a loss and was hoping that some one might have an insite to my problem or some tips.
justinsoltis is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-09-2010, 09:24 PM
1/4 Throttle
 
Join Date: Feb 2010
Posts: 9
i had some leakage.with mine........i left a small piece of the gasket on the motor side. once i got it good and clean no more leak
05 rhino is offline  
post #3 of 4 (permalink) Old 03-09-2010, 09:26 PM
1/4 Throttle
 
Join Date: Feb 2010
Posts: 9
also the gasket will push out on the bottom so be careful when you tighten it up.....been there done that....lol
05 rhino is offline  
 
post #4 of 4 (permalink) Old 03-11-2010, 07:09 AM Thread Starter
1/4 Throttle
 
justinsoltis's Avatar
 
Join Date: Mar 2010
Location: Rock Springs Wy
Posts: 4
yeah I have done all the carefull steps the problem is I cant see where the oil is leaking from so i have no clue where to fix the oil leak I am going to try and jack up the rear end and run the rhino in gear all the while looking for where the oil is leaking because it doesn't leak when it in nuetral and you rev it up so I am going to try that
justinsoltis is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57