yamaha rhino 700 shifting issue?? - Yamaha Rhino Forums - Yamaha UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-15-2014, 02:52 PM Thread Starter
1/4 Throttle
 
Join Date: Apr 2014
Posts: 2
yamaha rhino 700 shifting issue??

I have a 08 rhino 700,took it out on trails for first time last weekend got into sum pretty deep water and belt was slipping,so we drained water outta housing,and seemed to be fine but then when running in hi gear,it dosent wanna shift.into higher gear. I had to drive it home at 10mph.any input will b appreciated.im new to all this
steviebryan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-15-2014, 08:59 PM
1/4 Throttle
 
ACAMS's Avatar
 
Join Date: Apr 2014
Posts: 5
It takes a while to dry out.
You should have rode trails and not let it slip for a couple miles.

ACAMS is offline  
post #3 of 3 (permalink) Old 04-15-2014, 09:20 PM Thread Starter
1/4 Throttle
 
Join Date: Apr 2014
Posts: 2
Quote:
Originally Posted by ACAMS View Post
It takes a while to dry out.
You should have rode trails and not let it slip for a couple miles.
Think I toasted the belt ? Haven't tried it out n couple days to c if it's still jacked up.
steviebryan is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57