Hey everybody - Yamaha Rhino Forums - Yamaha UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-16-2009, 04:01 PM Thread Starter
 
Join Date: Dec 2009
Posts: 1
Hey everybody

Hey guys, I have been staking for a few days. I just bought a used '05 660 Camo off from Craigs List. Sold a couple of snowmobiles. Needed a sxs for the property. Got it home wouldn't shift into reverse. actually it shifted into reverse twice. Once when I first got home and then one other time. But now it just doesn't. It also has an oil leak somewhere. The sellar said "I just changed the oil and over filled it a little"...yeah whatever... I took it to a dealer to find the leak and to make it go backwards and for the updates and to install the almost new IPTs and tires that I bought yesterday too. Now those are in very nice condition. I actually bought the tires from a Yamaha Rep. Anyway. Thanks in advance from this novice nb. I will need help. Hope that the problems with this unit are minor. Thing runs great...forward only but great just the same.

Last edited by SXCXC; 12-16-2009 at 04:15 PM.
SXCXC is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58