Rhino has plenty of fuel but seems to be starving for gas - Yamaha Rhino Forums - Yamaha UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 07-07-2010, 06:34 PM Thread Starter
1/4 Throttle
 
Join Date: Jul 2010
Posts: 5
Rhino has plenty of fuel but seems to be starving for gas

I have a 2006 Rhino, which up to now ran beautifully. Lately it will run normally, but then start spitting and sputtering and then finally quit. You can wait a a couple of minutes and then it run normally for a while. It acts like it has a vapor lock, but today I couldn't see any collapsed hoses. I did notice the fuel in the fuel filter was only up in the sight glass about a 1/4". Could it be a fuel pump issue? Where is the fuel pump located?
woram67 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 08-03-2010, 10:16 AM
1/4 Throttle
 
Join Date: Aug 2010
Posts: 1
i have the same trouble and so does two of my freinds.

Last edited by ggregory55; 08-03-2010 at 10:24 AM.
ggregory55 is offline  
post #3 of 15 (permalink) Old 08-03-2010, 11:03 AM
RhinoTalk.net Site Sponsor
 
Bryan M's Avatar
 
Join Date: Jun 2008
Location: ummmmmm Im not sure..fuck, I think were lost!
Posts: 1,377
have you changed the fuel filter? it sounds clogged.... and then yes, your next step would be the pump...and theyre very easy to change out

If you live in Vegas and need a General Contractor...call Manning Construction @ 497-5127
Bryan M is offline  
 
post #4 of 15 (permalink) Old 08-03-2010, 11:22 AM
Wide F'n Open
 
Join Date: Jun 2008
Posts: 121
Definitely sounds like the fuel filter. Always carry a spare.
Wild Earp is offline  
post #5 of 15 (permalink) Old 08-03-2010, 12:56 PM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
a few things can cause this.

silicone in the pickup line in the tank. ( seen it on mine)

dirty fuel filter.

weak pump

cracked vacuum line to pump ( needs this to operate)

pinched fuel line from pump to tank, ( pinched under engine cover)

sticky needle/seat in carb bowl

plugged tank vent line/check valve or Gas cap, run then open cap and listen for air



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
post #6 of 15 (permalink) Old 08-03-2010, 12:57 PM
RhinoTalk.net Site Sponsor
 
Bryan M's Avatar
 
Join Date: Jun 2008
Location: ummmmmm Im not sure..fuck, I think were lost!
Posts: 1,377
you could also have a crack in the "T" fitting pickup for the fuel lines at the tank

If you live in Vegas and need a General Contractor...call Manning Construction @ 497-5127
Bryan M is offline  
post #7 of 15 (permalink) Old 08-03-2010, 12:58 PM
RhinoTalk.net Site Sponsor
 
Bryan M's Avatar
 
Join Date: Jun 2008
Location: ummmmmm Im not sure..fuck, I think were lost!
Posts: 1,377
ha rog you posted 2 sec faster then me with all the stuff I was gonna ad...damn ya ninjaed me

If you live in Vegas and need a General Contractor...call Manning Construction @ 497-5127
Bryan M is offline  
post #8 of 15 (permalink) Old 08-03-2010, 06:44 PM Thread Starter
1/4 Throttle
 
Join Date: Jul 2010
Posts: 5
It doesn't starve for gas all the time, its very sporadic. Sometimes when the engine is cold and sometimes after riding for an hour. If it was a dirty fuel filter, wouldn't it starve for gas all the time? The fuel filter looks very clean, but could it still be partially stopped up?

I'm betting on a weak fuel pump. Are the after markets ones better than the OEMs?
woram67 is offline  
post #9 of 15 (permalink) Old 08-04-2010, 10:59 AM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
Quote:
Originally Posted by Bryan M View Post
ha rog you posted 2 sec faster then me with all the stuff I was gonna ad...damn ya ninjaed me
rainman on top of it! lol



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
post #10 of 15 (permalink) Old 08-04-2010, 11:02 AM
RhinoTalk.net Site Sponsor
 
Bryan M's Avatar
 
Join Date: Jun 2008
Location: ummmmmm Im not sure..fuck, I think were lost!
Posts: 1,377
what could be happening is you have these lil pieces of gunk in your tank(silicone that they used in the manf. process) sometimes while your driving it comes up to the filter and partially blocks it then when your off throttle it falls back down into the line or tank..only way to fix is pull the tank and clean it...

If you live in Vegas and need a General Contractor...call Manning Construction @ 497-5127
Bryan M is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58