04 660 rhino wont start - Yamaha Rhino Forums - Yamaha UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-03-2010, 01:59 AM Thread Starter
1/4 Throttle
 
Join Date: Aug 2010
Posts: 9
04 660 rhino wont start

My 2004 rhino cranks but wont start. I was riding and it lost all power and died. The key was hard to turn and would stay in the crank position. I towed it home and changed one of the 30 amp fuses. Now it has power but when I turn the key to on something clicks in the battery box. It will crank but doesnt seem to be firing.
da boss is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-05-2010, 11:47 AM Thread Starter
1/4 Throttle
 
Join Date: Aug 2010
Posts: 9
I changed the ignition switch, spark plug and charged the battery. It cranks good and is firing at the spark plug cap but still wont start..... any ideals anyone????
da boss is offline  
post #3 of 5 (permalink) Old 08-05-2010, 12:22 PM
Red Cup Ninja
 
shonuff's Avatar
 
Join Date: Jun 2008
Location: murrieta,ca
Posts: 3,312
sounds like the cdi box took a shit... i would start by replacing that.

Fuck'em and feed'em cabbageI have found the richer your friends are.....the more they want you to suck their asses.......I guess these fools havent figured out yet I dont suck ass ~ the bigg anonymous
shonuff is offline  
 
post #4 of 5 (permalink) Old 08-05-2010, 07:13 PM
Wide F'n Open
 
Benzito's Avatar
 
Join Date: Aug 2009
Location: AZ
Posts: 300
also check ur fuel these loose vacumn all the time and it will shut off and be a pain in da ass 2 restart,

look at the fuel filter behind pass seat, also put ur hand or rag over intake hole to build up pressure , or spray a lil starting fluid or carb clean as ur cranking i bet it will fire up

2007 660 SE - DUAL MUZZY - K&N SET UP - INNOVATE WIDEBAND TUNED - RUGGED RACE RADIO - GEAR ONE RACK -

http://performancetruckproducts.com/

http://www.unleashedutv.com/

http://traillogicllc.com/
Benzito is offline  
post #5 of 5 (permalink) Old 08-09-2010, 09:59 AM Thread Starter
1/4 Throttle
 
Join Date: Aug 2010
Posts: 9
checked cdi but wasnt it. It had back fired when it died and it blew the intake off the carb. put it back on and it fired up. thank yaw for your help now i have broke an axle
da boss is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58