Introduction - Yamaha Rhino Forums - Yamaha UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-05-2011, 04:21 PM Thread Starter
1/4 Throttle
 
Join Date: Jun 2011
Posts: 1
Introduction

Hello Eveyone. New member Randy Fife here. I joined in hopes of getting some answers to an engine cut-out problem. I have an 07 - 660 with a high compression kit; includes cam, exhaust, and an Edlebrock carb including the electric fuel pump. It's always run fine, a little hard to start (just turn over). Now it after I go just several humdred yards, the engine dies like soneone turned off the key. It starts right up again and goes for a while short longer and cuts out again. I've changed many parts including the spark plug, coil, plug wire and cap, safety neutral switch, cleaned the carb, emptied the fuel tank and added fresh high test gas, fuel filter, removed air filter. I don't know what next to try. I'm going to hook up a Fluke meter next and run the thing until it cuts out and see if there's a voltage drop when it cuts out. Anyone have any suggestions?
Thanks, Randy Fife.
RandyFife is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-21-2011, 09:01 PM
1/4 Throttle
 
Join Date: Jun 2011
Posts: 1
Open the radiator cap, start the rhino stomp on the gas pedal, if radiator fluid overflows this may be a blown head gasket. On rhinos it is very common for normal running w a blown head gasket until engine is hot or reved out.
Msts486 is offline  
post #3 of 3 (permalink) Old 06-22-2011, 08:29 PM
3/4 Throttle
 
bender.chris5908's Avatar
 
Join Date: Aug 2009
Location: hughesville,pa
Posts: 91
Garage
check that head gasket.. I have been replacing head gaskets every week on the 700 rhinos.. Also Check output on the pickup coil.. Try unplugging the regulator and running it also..
bender.chris5908 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58