Overheating - Yamaha Rhino Forums - Yamaha UTV Forum
Member Introductions We are happy to have you with us, please take a moment to introduce yourself to the rest of the members.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 09-17-2012, 01:25 PM Thread Starter
1/4 Throttle
 
Join Date: Sep 2012
Posts: 1
Overheating

Any suggestions for solving overheating problem with Rhino. Fan works, radiator clean, full of fluid, ???
BillySilcox is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 09-18-2012, 02:20 PM
1/4 Throttle
 
Join Date: Sep 2012
Location: Las Vegas, NV
Posts: 2
water pump not working or some other type of blockage that is preventing circulation of the coolant.
gmorris0562 is offline  
post #3 of 7 (permalink) Old 09-18-2012, 03:47 PM
1/4 Throttle
 
Join Date: Aug 2012
Posts: 5
Have you done any motor work or do you have an oversized radiator. Mine just overheated last weekend and it was hot out and i was riding in the sand. I think I Just pushed it to hard in the heat and i have done the 686 kit . I am looking to get an oversized radiator next as i am doing that right now on my banshee. It keeps overheating as well.
rhinokid is offline  
 
post #4 of 7 (permalink) Old 09-18-2012, 04:43 PM
1/4 Throttle
 
Join Date: Jun 2012
Posts: 4
Hot light

my 07 660 rhino has the hot light stayes on all the time even after set all night will be on WHAT THE HECK?? HELP
wconnell is offline  
post #5 of 7 (permalink) Old 09-18-2012, 10:37 PM
1/4 Throttle
 
Join Date: Aug 2012
Posts: 5
check to see if the wire on the sending unit I think it is on the thermostat housing. if the wire is connected try to short the wire out to ground and see if the light goes out. do you have a temp guage and a light or just the light.
rhinokid is offline  
post #6 of 7 (permalink) Old 09-19-2012, 05:45 PM
1/4 Throttle
 
Join Date: Jun 2012
Posts: 4
thanks rhinokid mine only has light wire and conection had crossion on it cleaned it and light went out iam 60 years old and love mud riding just a old kid at heart again thank much
wconnell is offline  
post #7 of 7 (permalink) Old 09-24-2012, 03:58 PM
1/4 Throttle
 
Join Date: Aug 2012
Posts: 5
no problem glad it worked out for you.
rhinokid is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57