Yamaha Rhino Forums - Yamaha UTV Forum - Reply to Topic
Yamaha Rhino Engine Swap Discussions Yamaha Rhino engine swap discussions.
Rotax swap, R1 swap, etc.

Thread: Rotax oil cooler.. Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-07-2009 01:02 PM
max powers
Quote:
Originally Posted by Mush View Post
So your seeing standard temps at most times with a built motor and duneing in abnormal temps bitchen !!!!!!
on pump gas to
09-07-2009 12:27 PM
Mush So your seeing standard temps at most times with a built motor and duneing in abnormal temps bitchen !!!!!!
09-07-2009 11:26 AM
max powers
Quote:
Originally Posted by Brian B View Post
Are you running a thermostat? Fan always on?
I think the stat is in there and no the fan comes on at 180
09-07-2009 11:25 AM
Brian B Are you running a thermostat? Fan always on?
09-06-2009 05:16 PM
max powers Not sure you could judge from mine cause my sender is up by the radiator, but it never went over 210, I can leave it idoling and it will never go over 150
09-06-2009 04:18 PM
warlock what kind of temps were you seeing
09-06-2009 02:57 PM
max powers
Quote:
Originally Posted by Brian B View Post
How did that coolant adapter I sent you work out?
I was on my way back down olds hwy and one end popped off, guess I forgot to tighten the hoseclamp enough, other than that, it worked perfect, I have the other one for you when I see you next. thanks again
09-06-2009 02:52 PM
Brian B How did that coolant adapter I sent you work out?
09-06-2009 02:29 PM
max powers
Quote:
Originally Posted by warlock View Post
Hey Mark do you have a water temp gauge.
yes sir, and I'm running evans pro coolant
09-06-2009 02:13 PM
warlock
Quote:
Originally Posted by max powers View Post
mine is all up and running, I used an exterior filter, K+n177
fits perfect, ran a b+m oil cooler in the stock rhino location, ran it out in the heat in glamis last weekend and my oil stayed nice and cool.
Hey Mark do you have a water temp gauge.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58