Wet clutch - Yamaha Rhino Forums - Yamaha UTV Forum
Want Ads Want or need something specific, post your want ads in here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-12-2009, 08:52 AM Thread Starter
Wide F'n Open
 
sandjunky's Avatar
 
Join Date: Oct 2008
Location: Sacramento
Posts: 596
Wet clutch

this is the last part that i have not changed out yet and i hope its the problem. i keep stiping out the fixed sheave splines and i am not sure why. i went out this weekend and it only lasted about 45mins. it felt like i had some lost of power, so i pulled over and she was smoked. i think thats what was causing the belt to blow out. it would still drive, but it felt like the parking break on. anybody have any other ideas why this dam thing keeps blowing out? this will be my fourth fix sheave
sandjunky is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57