Help !...please - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Electrical Discussions Yamaha Rhino electrical discussions.
Lighting, audio, GPS, communications, etc.
Maintenance, cleaning, etc.
Off-topic posts should be put in the Off-Topic Forum.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 43 (permalink) Old 09-06-2008, 02:44 PM Thread Starter
Founding Ninja
 
Trooper522's Avatar
 
Join Date: Jun 2008
Location: San Diego
Posts: 1,131
Help !...please

I went out to go start my rhino and Im getting a clicking noise from the battery compartment I narrowed it down to some sort of relay, may be the solenoid not sure exactly but if you follow the positive lead from the battery it plugs in to this component....this is whats clicking I tried to start it with my battery charger and it still does the same thing....could it be my battery ? it has been on the low side.....please help guys, thanks
Trooper522 is offline  
Sponsored Links
Advertisement
 
post #2 of 43 (permalink) Old 09-06-2008, 02:45 PM
Founding Ninja
 
goodguys75's Avatar
 
Join Date: Jun 2008
Location: vegas
Posts: 466
Quote:
Originally Posted by Trooper522 View Post
I went out to go start my rhino and Im getting a clicking noise from the battery compartment I narrowed it down to some sort of relay, may be the solenoid not sure exactly but if you follow the positive lead from the battery it plugs in to this component....this is whats clicking I tried to start it with my battery charger and it still does the same thing....could it be my battery ? it has been on the low side.....please help guys, thanks
not 100% sure but it is probably a dead/bad batt, try to charge first and see if it turns over

JUST SAY NO TO C**K SNAPPING

IM RICK JAMES BIOTCH!!!!!

http://www.dumontduneriders.com/imag...ers/468x60.jpg
goodguys75 is offline  
post #3 of 43 (permalink) Old 09-06-2008, 02:49 PM Thread Starter
Founding Ninja
 
Trooper522's Avatar
 
Join Date: Jun 2008
Location: San Diego
Posts: 1,131
My charger says its charged and normally when it is low and I install the charger it starts imediatly.
Trooper522 is offline  
 
post #4 of 43 (permalink) Old 09-06-2008, 02:52 PM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Check you connections make sure everything is tight



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #5 of 43 (permalink) Old 09-06-2008, 02:55 PM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
I think dead/bad battery, But make sure your connections are good. Is your charger turning on?
dirtysidedown is offline  
post #6 of 43 (permalink) Old 09-06-2008, 02:59 PM Thread Starter
Founding Ninja
 
Trooper522's Avatar
 
Join Date: Jun 2008
Location: San Diego
Posts: 1,131
Quote:
Originally Posted by BiggJim View Post
Check you connections make sure everything is tight
Thanks Jim I will check everything

Quote:
Originally Posted by dirtysidedown View Post
I think dead/bad battery, But make sure your connections are good. Is your charger turning on?
Yep charge is on and shows full charge
Trooper522 is offline  
post #7 of 43 (permalink) Old 09-06-2008, 03:01 PM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
Is it a single click or a bunch of them? -click or click,click,click like someone dropped a bb on the floor?
dirtysidedown is offline  
post #8 of 43 (permalink) Old 09-06-2008, 03:03 PM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
bad connection, bad ground, or bad battery is my guess

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
post #9 of 43 (permalink) Old 09-06-2008, 03:04 PM
Founding Ninja
 
goodguys75's Avatar
 
Join Date: Jun 2008
Location: vegas
Posts: 466
Quote:
Originally Posted by dirtysidedown View Post
Is it a single click or a bunch of them? -click or click,click,click like someone dropped a bb on the floor?
can you say that again? not sure what you mean.....lol

JUST SAY NO TO C**K SNAPPING

IM RICK JAMES BIOTCH!!!!!

http://www.dumontduneriders.com/imag...ers/468x60.jpg
goodguys75 is offline  
post #10 of 43 (permalink) Old 09-06-2008, 03:04 PM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
Troop, do you have a volt meter??

COnnections--- both on batt, ground on engine block
hot wire on top of starter


sounds like a weak batt though

Rog



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58