Ignition relay doesn’t match wiring. - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Electrical Discussions Yamaha Rhino electrical discussions.
Lighting, audio, GPS, communications, etc.
Maintenance, cleaning, etc.
Off-topic posts should be put in the Off-Topic Forum.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-26-2018, 08:26 PM Thread Starter
1/4 Throttle
 
Join Date: Dec 2018
Posts: 2
Ignition relay doesn’t match wiring.

I’ve ordered two ignition relays for my rhino 660. One OEM and one aftermarket from two different companies. They are the two on the left on the picture but the one in my rhino looks like this so the prongs don’t match. I don’t understand why they don’t match or what to do.
Attached Images
File Type: jpg F0D8252C-6139-4A64-A934-6C094CD6370E_1545881029491.jpg (28.6 KB, 7 views)
green tunic is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-28-2018, 05:11 AM
3/4 Throttle
 
Steve Osborne's Avatar
 
Join Date: Oct 2018
Posts: 57
I just replaced mine on a 2011 700 efi.... it matches the new ones you have....either they gave you the wrong part or you need to update the pigtail/plug..
Steve Osborne is offline  
post #3 of 5 (permalink) Old 12-28-2018, 05:23 AM
3/4 Throttle
 
Steve Osborne's Avatar
 
Join Date: Oct 2018
Posts: 57
new one # 5b4-81940-00-00 comes up 2009-up

think your looking for this one..
#5ug-81940-00-00 this one shows to 2009.. if yours is 2009... maybe a crossover year and parts got updated part way in the year..

this is another one shown 700 ATV and wave runners..
#5s7-81940-00-00
Attached Images
File Type: jpg s-l400.jpg (23.5 KB, 1 views)

Last edited by Steve Osborne; 12-28-2018 at 05:48 AM.
Steve Osborne is offline  
 
post #4 of 5 (permalink) Old 01-18-2019, 05:27 PM Thread Starter
1/4 Throttle
 
Join Date: Dec 2018
Posts: 2
#5ug-81940-00-00. Is the right part. I’m about to go put in, now Do you know why it’s the 5ug?
green tunic is offline  
post #5 of 5 (permalink) Old 01-21-2019, 04:27 PM
3/4 Throttle
 
Steve Osborne's Avatar
 
Join Date: Oct 2018
Posts: 57
Quote:
Originally Posted by green tunic View Post
#5ug-81940-00-00. Is the right part. Iím about to go put in, now Do you know why itís the 5ug?
maybe 2004 to 2009....then 2009 to 2013 is the newer one...model change or upgrade
Steve Osborne is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57