Any1 ever fried a dyna cdi by disconnecting battery while running???? - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Electrical Discussions Yamaha Rhino electrical discussions.
Lighting, audio, GPS, communications, etc.
Maintenance, cleaning, etc.
Off-topic posts should be put in the Off-Topic Forum.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-14-2009, 08:41 PM Thread Starter
 
Join Date: Aug 2008
Posts: 85
Any1 ever fried a dyna cdi by disconnecting battery while running????

my buddy disconnected his battery while running and his cdi fired.... Anyone know how this happens? I'm just helping him out with any info of what could have caused this????
SouthBayRhino is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-14-2009, 08:50 PM
Wide F'n Open
 
sandnuriz's Avatar
 
Join Date: Jun 2008
Location: Bakersfield, CA
Posts: 1,185
a buddy of mine has welding on his rig and fried his cdi
sandnuriz is offline  
post #3 of 5 (permalink) Old 02-14-2009, 10:07 PM Thread Starter
 
Join Date: Aug 2008
Posts: 85
Well, I guess that makes sense, I have heard of people blowing their computers on their cars from welding without disconnecting the battery first. but frying it by disconnecting battery makes me wonder wtf!!!
SouthBayRhino is offline  
 
post #4 of 5 (permalink) Old 02-15-2009, 11:12 AM
Wide F'n Open
 
Join Date: Oct 2008
Posts: 294
Quote:
Originally Posted by SouthBayRhino View Post
my buddy disconnected his battery while running and his cdi fired.... Anyone know how this happens? I'm just helping him out with any info of what could have caused this????
I fried one in my rhino;I guess the grease got too hot while i waiting for the bisquits to get done..
poflo is offline  
post #5 of 5 (permalink) Old 02-17-2009, 12:33 PM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
why the hell would he do that anyway????



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
660 motor running or not! nvs2none Yamaha Rhino's & Rhino Parts For Sale 5 02-18-2009 09:03 AM
2007 Screamin Eagle Dyna Python Misc Items For Sale 3 12-31-2008 04:08 PM
Rhino 660 Dyna FS Ignition HRT Motorsports Yamaha Rhino's & Rhino Parts For Sale 0 12-24-2008 11:51 AM
Programable dyna ignition help SandNu How-To's 2 12-14-2008 05:34 PM
Anyone use DR.D programmer and Dyna ECU? mopar_enthusiast Yamaha Rhino Performance Discussions 4 07-02-2008 11:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58