Dash In Op - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Electrical Discussions Yamaha Rhino electrical discussions.
Lighting, audio, GPS, communications, etc.
Maintenance, cleaning, etc.
Off-topic posts should be put in the Off-Topic Forum.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 04-13-2009, 08:15 PM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Dash In Op

07 Rhino everything runs and functions great but no dash read outs at all. Dash lights up? This is a new dash the previous did the samething? Swaped CDI's samething. Checked all fuses, fresh battery, checked all connectors and wiring. Any suggestions?
Throttle Fever is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-14-2009, 08:09 AM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Is there nobody up on the inner work of the digital dash?? This thing is got me a little puzzled. Noticed plenty of questions on the site about them, but not many answers? Looking at the wiring schematics its pretty straight forward, but I must be missing something. Hinded diode, fuse or sensor?
Throttle Fever is offline  
post #3 of 11 (permalink) Old 04-14-2009, 08:30 AM
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
got me on this one is there a way to test the dash with a multimeter? maybe a broken board in the dash it's self, you have checked all the obvious with fuses and cdi boxes, i would start looking at the dash itself if it were me. what kind of cdi were you running, could it be going bad and voltage spike and kill it? did you check with the OG CDI? what other electrical upgrades do you have alternator??

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
 
post #4 of 11 (permalink) Old 04-14-2009, 08:41 AM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Tried both stock and Dynatek CDI, same results? Have two dashes both doing the same thing? No other mod's. Charging system working fine? I don't know, niether does the dealer. Hmm Tested voltage to the dash, ok. Checked all grounds, ok. Testing the dash, I would not know what resistance or ohm value to call good or bad. The schematic is not to much help on the dash stuff. I am sure it is something small that I am overlooking. Speed Sensor? Hmm
Throttle Fever is offline  
post #5 of 11 (permalink) Old 04-14-2009, 10:47 AM
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
maybe check the fuel sending wires as well, a short in any of these locations could wreek havoc i would think. speed sensor, 4X switch ect..

you got the 100$ mystery there bro.

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
post #6 of 11 (permalink) Old 04-14-2009, 12:34 PM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Ya I'll give them a look. Wonder if the dash needs a signal from the stator, (like a exciter wire on a alternator) that it may not be getting? Guess I will dive into the schematic again tonite. I appreciate the input.......
Throttle Fever is offline  
post #7 of 11 (permalink) Old 04-17-2009, 04:41 PM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Just a update to those that are following. Had a buddy of mine from a local dealer stop by. Wow I now he is a friend but Yamaha does'nt train them well. We ohmed all of the wiring harness, again (I already did it once). And found all was well. Pulled all sensors and switches and ohmed (again), all good. So the dash still only lites up (back light) and has no read outs. Must be a secret fuse or diode in the harness somewhere I have not found yet. Will update again when I get it working (on a quest now). It has to be somthing simple did all the hard stuff already?? Then I will probably yank it all and install manual gauges.
Throttle Fever is offline  
post #8 of 11 (permalink) Old 04-30-2009, 09:32 PM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Just a update: Found the issue. Got board the other nite and stripped the wiring harness. Down in the belly pan part of the wiring harness there is a crimp were Yamaha puts three wires together with a little brass crimp type connector. Well the harness also collects a bunch of water in it, so needless to say the crimp and wires were corroded. Stripped the the wires back and removed the crimp. Soldier and heat shrinked the three together. Bingo dash works great. If you have any electrical issues I think these crimps have the potential to be a nightmare. There is a total of 4 that I found in the front harness that I removed while there and repaired correctly. Soldiered and heat shrunk.
Throttle Fever is offline  
post #9 of 11 (permalink) Old 04-30-2009, 09:43 PM
Wide F'n Open
 
Join Date: Jun 2008
Posts: 1,618
Quote:
Originally Posted by Throttle Fever View Post
Just a update: Found the issue. Got board the other nite and stripped the wiring harness. Down in the belly pan part of the wiring harness there is a crimp were Yamaha puts three wires together with a little brass crimp type connector. Well the harness also collects a bunch of water in it, so needless to say the crimp and wires were corroded. Stripped the the wires back and removed the crimp. Soldier and heat shrinked the three together. Bingo dash works great. If you have any electrical issues I think these crimps have the potential to be a nightmare. There is a total of 4 that I found in the front harness that I removed while there and repaired correctly. Soldiered and heat shrunk.
Guess you didn't need my gauge after all..
controled force is offline  
post #10 of 11 (permalink) Old 04-30-2009, 09:55 PM Thread Starter
 
Join Date: Apr 2009
Posts: 27
Whats up?? It was the cheapest way to test mine. Yamaha has no clue when it comes to troubleshooting these things. It's up for sale. I will let you have it back for, say, $100.00 shipped..............
Throttle Fever is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
OEM 2008 Digital Dash Juanos Yamaha Rhino's & Rhino Parts For Sale 8 12-30-2009 05:28 PM
Gas gauge in OEM dash Dodgecummins Yamaha Rhino Electrical Discussions 8 12-03-2009 06:20 AM
Digital Dash Teebone56 Yamaha Rhino's & Rhino Parts For Sale 15 04-11-2009 07:04 PM
TrailTech HID MR11 with dash bar Generalg Yamaha Rhino's & Rhino Parts For Sale 4 12-18-2008 10:35 AM
MDR new Years Dash RedneckMotorsports UTV Desert Racing 39 12-16-2008 05:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58