09 700 Speed Demon, WHY? - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Electrical Discussions Yamaha Rhino electrical discussions.
Lighting, audio, GPS, communications, etc.
Maintenance, cleaning, etc.
Off-topic posts should be put in the Off-Topic Forum.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-25-2013, 03:10 PM Thread Starter
1/4 Throttle
 
Join Date: Aug 2010
Location: Oregon
Posts: 9
09 700 Speed Demon, WHY?

While in the process of tracking down an intermittent signal to the fuel system I replaced the air filter with a K&N, replaced the crank sensor and the ignition coil with an aftermarket unit.
When I can get it to run, it went from 40 MPH max to 65MPH! What Happened?

I am now looking at the wiring harness for the intermittent signal because I have replaced everything else. The OEM manual will arrive
shortly.
RandyRhino is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-01-2013, 03:11 PM Thread Starter
1/4 Throttle
 
Join Date: Aug 2010
Location: Oregon
Posts: 9
Quote:
Originally Posted by RandyRhino View Post
While in the process of tracking down an intermittent signal to the fuel system I replaced the air filter with a K&N, replaced the crank sensor and the ignition coil with an aftermarket unit.
When I can get it to run, it went from 40 MPH max to 65MPH! What Happened?

I am now looking at the wiring harness for the intermittent signal because I have replaced everything else. The OEM manual will arrive
shortly.
My Clymer manual came. The fule injector and the pump are on the same relay.
Wiggle the wires and no problem (after $500 parts and labor run around).
RandyRhino is offline  
post #3 of 3 (permalink) Old 05-02-2013, 09:55 PM
1/4 Throttle
 
dodgeboykim's Avatar
 
Join Date: Feb 2012
Location: chilliwack. b.c. canada
Posts: 10
Seems to me there is a sensor/switch that when you put it in reverse it limits speed/rpm etc. A buddy of mine found his to be bad so he replaced it and that fixed it. Some of your symptoms sound just like his were.
Not sure where it is.
dodgeboykim is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58