Rotax cooling setups? Whats yours? - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Engine Swap Discussions Yamaha Rhino engine swap discussions.
Rotax swap, R1 swap, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 05-18-2009, 07:17 PM Thread Starter
Wide F'n Open
 
Brian B's Avatar
 
Join Date: Feb 2009
Posts: 259
Rotax cooling setups? Whats yours?

What are you guys running for cooling setups?

Stock thermostat? No thermostat?

Stock cooling fan wiring?

Fan on - key on?

Thanks!

Rotax Your Rhino
Brian B is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 05-18-2009, 08:35 PM
Wide F'n Open
 
QwkRhino's Avatar
 
Join Date: Jul 2008
Location: Whittier SolCal
Posts: 770
Stock thermostat, Stock cooling fan wiring with over ride switch.
QwkRhino is offline  
post #3 of 16 (permalink) Old 05-19-2009, 07:43 AM
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
all stock. with engine ice, wrapped header, and cvt cover mod

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
 
post #4 of 16 (permalink) Old 05-19-2009, 07:54 AM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
pwr rad, having my exhaust ceramic coated,all rest stock, but may have to try some things with the new 840 if she runs hot

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
post #5 of 16 (permalink) Old 05-19-2009, 10:14 AM Thread Starter
Wide F'n Open
 
Brian B's Avatar
 
Join Date: Feb 2009
Posts: 259
What temps are you guys running at? "Fan-on" temp?

Anyone make a cooler thermostat for these engines?

Thanks!

Rotax Your Rhino
Brian B is offline  
post #6 of 16 (permalink) Old 05-19-2009, 10:34 AM
LBR
Administrator
 
LBR's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 267
FYI - In the Outlander manual I found some specs some time back - It seems that the fan was triggered on @ 208 degrees and off @ 203 degrees coolant temp. Another sensor read intake manifold temp and triggered the fan on @195 degrees and off @ 190 degrees.....or real close to those specs....LBR
LBR is offline  
post #7 of 16 (permalink) Old 05-19-2009, 10:52 AM
Wide F'n Open
 
QwkRhino's Avatar
 
Join Date: Jul 2008
Location: Whittier SolCal
Posts: 770
Quote:
Originally Posted by Brian B View Post
What temps are you guys running at? "Fan-on" temp?

Anyone make a cooler thermostat for these engines?

Thanks!
Fan on cruzin you can get down to 185 but most of the time it wants to run at 210 have not found a cooler t stat the stock on opens at 165 degs f.
QwkRhino is offline  
post #8 of 16 (permalink) Old 05-26-2009, 12:11 PM
NO8
1/4 Throttle
 
Join Date: Jan 2009
Posts: 14
ceramic coated headers, inside out. pc3 and next a extra fan to suck air into engine compartment.
NO8 is offline  
post #9 of 16 (permalink) Old 06-05-2009, 04:34 PM Thread Starter
Wide F'n Open
 
Brian B's Avatar
 
Join Date: Feb 2009
Posts: 259
Quote:
Originally Posted by LBR View Post
FYI - In the Outlander manual I found some specs some time back - It seems that the fan was triggered on @ 208 degrees and off @ 203 degrees coolant temp. Another sensor read intake manifold temp and triggered the fan on @195 degrees and off @ 190 degrees.....or real close to those specs....LBR
I hit 210 on my digital autometer yesterday before I shut it off. Fan didnt come on, and it was in limp mode when I turned the key back on.

The fan should definitely come on around 190. 208 is way too high!

Rotax Your Rhino
Brian B is offline  
post #10 of 16 (permalink) Old 06-05-2009, 05:52 PM
LBR
Administrator
 
LBR's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 267
Quote:
Originally Posted by Brian B View Post
I hit 210 on my digital autometer yesterday before I shut it off. Fan didnt come on, and it was in limp mode when I turned the key back on.

The fan should definitely come on around 190. 208 is way too high!
Hi Brian - did you pull the code for limp home mode yet? Curious if it was for the temp - probably was. Several have posted that these monsters will throw the code if run fair hard and shut right down and not let idle for a couple of minutes to cool with circulation. I installed an Autometer 270 sweep Colbalt analog gauge with the sensor about 1' from the thermostat housing getting the hottest reading. Setting in the shop idleing, my fan kicks on @ 220 and off @209. When I unplug the engine temp sensor wire (pass side @ front cyl), fan comes on and stays on and will pull temps down to 155. When I got the CPU flashed Wednesday, I asked CanAm tech about the fan on @220/off @ 209 and was told is OK for the 800. If I start the cold engine with the fan on right away, it won't get above 140 in the shop. Ran it on my back roads and fan never came on once the whole time. Gad, so many different opinions starting to confuse LBR. LBR
LBR is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rotax Clutch Setups THUNDERUSONE Yamaha Rhino Engine Swap Discussions 8 03-18-2009 09:08 PM
Big bore cooling issues Xtremetoyzracing Yamaha Rhino Performance Discussions 19 02-28-2009 01:13 PM
Rotax Air cleaner setups lvautopro Yamaha Rhino Engine Swap Discussions 21 12-23-2008 06:44 PM
Whats up Spango Member Introductions 15 11-11-2008 07:24 AM
Whats next?? stetler Off-Topic Discussions 14 11-03-2008 09:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57