I lost my Top Speed - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 56 (permalink) Old 09-08-2008, 03:50 PM Thread Starter
Super Moderator
 
mikef's Avatar
 
Join Date: Jun 2008
Location: Inland Empire (Beumont, Ca.)
Posts: 1,068
I lost my Top Speed

Hey Guys....

I took my Rhino out for a quick ride last night.... I could only get it up to about 48 - 50 mph. The RPM's were pretty high. I could barely keep up with my brothers Rhino and he dont even have a sheave. He only has a CDI. I have a KMS Sheave....

My thought is that maybe the belt is getting a little worn or maybe for some reason the rollers are not able to go out all of the way.... But I am not sure why would start out of no where... I have close to 3500 miles on my KMS Sheave. Is there anyway that it can wear down? Maybe the roller tracks get a low spot in them?????

It was acting like I didnt have a mchined sheave... just a stock sheave.

I am looking for any thoughts or ideas before I tear it apart. I would like to get the parts here before I tear it apart.

2006 Rhino 660
BRP Stage 2 CDI
UTVCrap Sheave
4 Seat Cage w/42" Rear PRP Seat
ITP T-7C Wheels (5+2 front offset & 2+5 Rear)
Big Horn Tires (25x8x12 & 25x10x12)
LSR MTS +3 Mid Travel Kit
Bilstein Shocks w/ Eibach Springs 250lb front & 400lb rear
http://i105.photobucket.com/albums/m...BRP_Avatar.jpg http://i105.photobucket.com/albums/m...avatar/byc.jpg http://i105.photobucket.com/albums/m...r/uutv1211.jpg
mikef is offline  
Sponsored Links
Advertisement
 
post #2 of 56 (permalink) Old 09-08-2008, 03:53 PM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
I'd say your belt is going away.....Mine started to go away before it broke. I went from 50+ to 48 to 46 down to 44. It went away fast. I would bet its a belt issue



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #3 of 56 (permalink) Old 09-08-2008, 03:55 PM
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
while your at it slow your brothers rhino down, don't want him beatin ya.. lol I'd swap his CDI back to stock right before christmas, then wrap it up and give it to him again. lol

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
post #4 of 56 (permalink) Old 09-08-2008, 03:59 PM
Red Cup Ninja
 
shonuff's Avatar
 
Join Date: Jun 2008
Location: murrieta,ca
Posts: 3,312
if the belt is not an issue, than i would say regrease the sheave. the grease starts to get pretty nasty in a relatively short amount of time.

Fuck'em and feed'em cabbageI have found the richer your friends are.....the more they want you to suck their asses.......I guess these fools havent figured out yet I dont suck ass ~ the bigg anonymous
shonuff is offline  
post #5 of 56 (permalink) Old 09-08-2008, 04:09 PM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
being as you don't run a filter, you could have finaly clogged it up with dirt, also, Those pics of you running through waist deep water, well they could have rusted from sitting after that.belt could be worn, either way, you need to pull apart the clutch to get to the problem.

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
post #6 of 56 (permalink) Old 09-08-2008, 04:26 PM Thread Starter
Super Moderator
 
mikef's Avatar
 
Join Date: Jun 2008
Location: Inland Empire (Beumont, Ca.)
Posts: 1,068
Quote:
Originally Posted by max powers View Post
being as you don't run a filter, you could have finaly clogged it up with dirt, also, Those pics of you running through waist deep water, well they could have rusted from sitting after that.belt could be worn, either way, you need to pull apart the clutch to get to the problem.

LOL... You have a good memory. I have had the sheave apart since the water and mud. I was testing out different rollers. I had it apart about 6 months ago... well actually Custom Motorsports did it for me. I thought maybe they did something wrong but I dont think it would of took 6 months before I had a problem.

6 months ago they put it back to stock and packed it with new grease. No problems until now.

I am going to make some time in the next few days and tear it apart myself. I will probably go get a new belt just in case. I thought about calling KMS and having a new sheave overnighted and putting it in there just to make sure..... but I kind of wanted to see how long this one would last. I will just tear it apart and take a look.

2006 Rhino 660
BRP Stage 2 CDI
UTVCrap Sheave
4 Seat Cage w/42" Rear PRP Seat
ITP T-7C Wheels (5+2 front offset & 2+5 Rear)
Big Horn Tires (25x8x12 & 25x10x12)
LSR MTS +3 Mid Travel Kit
Bilstein Shocks w/ Eibach Springs 250lb front & 400lb rear
http://i105.photobucket.com/albums/m...BRP_Avatar.jpg http://i105.photobucket.com/albums/m...avatar/byc.jpg http://i105.photobucket.com/albums/m...r/uutv1211.jpg
mikef is offline  
post #7 of 56 (permalink) Old 09-08-2008, 04:28 PM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Quote:
Originally Posted by mikef View Post
LOL... You have a good memory. I have had the sheave apart since the water and mud. I was testing out different rollers. I had it apart about 6 months ago... well actually Custom Motorsports did it for me. I thought maybe they did something wrong but I dont think it would of took 6 months before I had a problem.

6 months ago they put it back to stock and packed it with new grease. No problems until now.

I am going to make some time in the next few days and tear it apart myself. I will probably go get a new belt just in case. I thought about calling KMS and having a new sheave overnighted and putting it in there just to make sure..... but I kind of wanted to see how long this one would last. I will just tear it apart and take a look.
I wouldnt order a new sheeve....I would think you would visually see the wear if it was that.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #8 of 56 (permalink) Old 09-08-2008, 05:08 PM
 
Join Date: Jun 2008
Posts: 225
i think my belt is slipping...seems slow and looks to be belt dust.

should i get yamaha or heavy duty?
i have a hi-comp 686
whats a good heavy duty belt? epi?

anyone change 2ndary springs also?
mx4life48 is offline  
post #9 of 56 (permalink) Old 09-08-2008, 05:10 PM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Quote:
Originally Posted by mx4life48 View Post
i think my belt is slipping...seems slow and looks to be belt dust.

should i get yamaha or heavy duty?
i have a hi-comp 686
whats a good heavy duty belt? epi?

anyone change 2ndary springs also?
Stick to the stocker



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #10 of 56 (permalink) Old 09-08-2008, 08:27 PM
jws
Wide F'n Open
 
jws's Avatar
 
Join Date: Aug 2008
Location: Ladera Ranch
Posts: 405
Quote:
Originally Posted by BiggJim View Post
I'd say your belt is going away.....Mine started to go away before it broke. I went from 50+ to 48 to 46 down to 44. It went away fast. I would bet its a belt issue

I am having this same thing with my MPH at 3000 miles - belt was ordered last week just need to get a KMS sheeve
jws is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost Footage From Olympics! dieselpowered Off-Topic Discussions 6 09-02-2008 10:44 PM
Palmer investigations (speed cameras) nappahdog Off-Topic Discussions 22 08-20-2008 11:58 PM
Speed chanel right now , UTVS **** Goodtimes Yamaha Rhino General Discussions 7 06-28-2008 11:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57