Engine Ice - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-27-2008, 10:52 AM Thread Starter
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
Engine Ice

Well finally did the deed and cut my CVT cover in half to reduce the hot ass air coming in the motor area, also installed a water temp gauge, not done ran outta female spade connectors, and rinsed and flushed the cooling system to add engine ice. I want to make sure i do this right the 1st, i completly drained the system flushed it 3 times with h2o and vinegar 50/50 mix, then jacked the front of the rhino as far as it will go removed both bleeder screws (v-twin suckas) and filled until engine ice was coming outta the bleeders, closed and ran for aminute and kept refilling the rad. do i need to continue to bleed, do i run the motor while filling it up som the pump keeps it moving, it seems i have more air in there, proabably what is in the engine it'self..

come on rog i now you have mad tech ninja skills,

also glued on the inner door upholstery, black carbon fiber viynal, thanks jimmy z looks great. be repin in dumont this weekend.

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-27-2008, 11:48 AM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
Run it until warm on gauge, let cool, check bleeders again, fill if needed.


Drive it around. let cool and check one last time, should be good to go.


Rog



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
post #3 of 9 (permalink) Old 10-27-2008, 11:58 AM Thread Starter
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
thanks rog,

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
post #4 of 9 (permalink) Old 10-27-2008, 12:09 PM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
When I installed my gauges it took 4 times to not see a drop in the level in the radiator after running it.

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
post #5 of 9 (permalink) Old 10-27-2008, 12:24 PM Thread Starter
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
yeah it keeps dropin on me too, thats why i am paranoid now, and am asking.lol i had to leak a fkn half gallon of engine ice on the ground from my 2 bleeder screws outta parnioa

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
post #6 of 9 (permalink) Old 10-27-2008, 12:28 PM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
I just kept heat cycling the engine and topping off the radiator. I only used the bleeders twice. Been fine for 150 miles now

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
post #7 of 9 (permalink) Old 10-27-2008, 12:31 PM Thread Starter
RhinoTalk.net Site Sponsor
 
Mush's Avatar
 
Join Date: Jun 2008
Location: Hendertucky NV
Posts: 3,207
do you run the engine with the rad cap off, or does that screw the loop system up? to heat cycle that is..

2007 3 seater razor eater
H-Town Performance for all your custom cage/bumper applications 702-564-7306
Mr. RPM BBK
Rigid E-Series
H-Town cage & bumper
Mush is offline  
post #8 of 9 (permalink) Old 10-27-2008, 01:06 PM
Wide F'n Open
 
QwkRhino's Avatar
 
Join Date: Jul 2008
Location: Whittier SolCal
Posts: 770
Quote:
Originally Posted by Mush View Post
Well finally did the deed and cut my CVT cover in half to reduce the hot ass air coming in the motor area, also installed a water temp gauge, not done ran outta female spade connectors, and rinsed and flushed the cooling system to add engine ice. I want to make sure i do this right the 1st, i completly drained the system flushed it 3 times with h2o and vinegar 50/50 mix, then jacked the front of the rhino as far as it will go removed both bleeder screws (v-twin suckas) and filled until engine ice was coming outta the bleeders, closed and ran for aminute and kept refilling the rad. do i need to continue to bleed, do i run the motor while filling it up som the pump keeps it moving, it seems i have more air in there, proabably what is in the engine it'self..

come on rog i now you have mad tech ninja skills,

also glued on the inner door upholstery, black carbon fiber viynal, thanks jimmy z looks great. be repin in dumont this weekend.
I just opened the to bleed and all so filled it up until it came out the bleeder. I'm running 50/50 colant and engine wetter. I added a fuidyne raditor with dual fans. motor was running around 210 all weekend. Fans turn on at 212 and turn off at 205. I never had any overheating problems weekend and it was 100 degrees out there. Thanks jimmy I also installed the door vinyl. Looks great.

Last edited by QwkRhino; 10-27-2008 at 08:06 PM.
QwkRhino is offline  
post #9 of 9 (permalink) Old 10-27-2008, 01:32 PM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
I had the cap on

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
660 engine temps? Bryan M Yamaha Rhino Performance Discussions 25 11-04-2008 05:25 PM
'07 Rhino 660 engine dying RHINOSTEVE Yamaha Rhino General Discussions 3 10-15-2008 10:11 AM
Engine Cover SXSCustms Want Ads 2 09-23-2008 12:51 PM
Stuck without an engine, help! PlanB43M Yamaha Rhino Performance Discussions 18 07-12-2008 06:26 PM
engine builds mx4life48 Yamaha Rhino Performance Discussions 24 06-30-2008 09:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57