2006 Temp light - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-01-2017, 09:22 AM Thread Starter
1/4 Throttle
 
CDNRhino's Avatar
 
Join Date: Oct 2017
Posts: 2
2006 Temp light

First time posting. I was driving my machine to and from my deer stand and it?s about 8k one way with no issues. I then park the bike for an hour or more and drive about 15 km.. the temp light started coming on and going off... I stopped the bike for 20 mins and started back to camp.. light started coming on and staying on. I checked and the coolant is full, fan was spinning and oil was good.
I checked the sensor wire on the engine between the seats. As soon as I pulled off the wire the light came on, put it back on.. light off... tried that a number of times same result... once on I wiggled it, no flickering in the light. Drove for about 8 km and no light.. just about to stop and light came on and off.
Bike sat all night (cool night). Drove to my tree stand and no light. Sat in tree stand for 3 hrs. Back at bike and as soon as I turned the key to ON.. light on and then off... shifted into reverse... light on and off... 8km Drive back to camp.. no light.
The exact same thing happened last year... almost identical situation.. not an issue since.
Buddy of mine said either a water pump issue or thermo switch?!?!
Opened the rad cap and some coolant spilt out..
Hoping someone had the same issue.
CDNRhino is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-01-2017, 11:54 PM
LBR
Administrator
 
LBR's Avatar
 
Join Date: Sep 2008
Location: Oregon
Posts: 269
Couple things come to mind besides a bad sensor...

You may have a steam pocket in cooling system that is under temp sensor, causing the fluctuations. You can try elevating the front way high and "burp" any air out the radiator cap.

Try attaching a good, temporary ground wire from battery to engine.
LBR is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57