Rhino 660 missing and sputtering - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-14-2019, 11:35 AM Thread Starter
1/4 Throttle
 
Join Date: Sep 2019
Posts: 1
Rhino 660 missing and sputtering

I have a 2006 Rhino 660. When you first start it, it will run fine. But after about 10 minutes, it will start sputtering and missing. Even if you turn it off and start again, it will continue to miss. Put a new fuel filter on it and a new breather. Thought that had solved the problem but it didn't. Can anyone give me any ideas what to do about it. Please don't suggest taking it to a shop. Can't afford that.

Johnny Johnson
Jonathan Johnson is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-28-2019, 09:44 PM
1/4 Throttle
 
BIGFOOTBOY's Avatar
 
Join Date: Sep 2019
Posts: 3
Have you cleaned the carburetor out that might help. I took mine off and cleaned all the jets out and used a tip cleaner for my torch to get all any debris out. Mine ran better, but no spark now so hope that helps
BIGFOOTBOY is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58