Sheave problem - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-13-2009, 11:30 PM Thread Starter
Wide F'n Open
 
GabeZ's Avatar
 
Join Date: Jun 2008
Location: Hemet Ca.
Posts: 659
Sheave problem

Has anybody had problems with your Sheave bolt? My neighbor cant seem to get the bolt to stay on and thinks its striped. Can this be replaced, should it be? Anyone ever have this problem? Help me get him out of my garage, please!

Open your mind, you might learn something!
GabeZ is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-14-2009, 08:08 AM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
What are you putting it on with? It has to be really tight. Try some loctite on it also

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
post #3 of 4 (permalink) Old 01-14-2009, 08:11 AM
jws
Wide F'n Open
 
jws's Avatar
 
Join Date: Aug 2008
Location: Ladera Ranch
Posts: 405
x2 Loctite
jws is offline  
post #4 of 4 (permalink) Old 01-14-2009, 09:48 AM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
Quote:
Originally Posted by GabeZ View Post
Has anybody had problems with your Sheave bolt? My neighbor cant seem to get the bolt to stay on and thinks its striped. Can this be replaced, should it be? Anyone ever have this problem? Help me get him out of my garage, please!
IMpact it on, also you need to make sure the washer is up over the splines and stays there when you tighten the nut, or it will come loose.

using a wrench or ratchet and socket does not cut it for the clutch nuts.

Rog



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BIG Front end problem !! Eat Dirt Yamaha Rhino General Discussions 37 12-19-2008 12:36 PM
CDI Problem (Dynatech) Dgrhinos Yamaha Rhino General Discussions 12 12-06-2008 12:19 PM
Front CV problem Need Help MMAD480 Yamaha Rhino General Discussions 10 11-30-2008 05:25 PM
Houston We Have A Problem! dieselpowered Other UTV Discussions 22 10-17-2008 04:09 PM
Does any one no the problem? sick08 Yamaha Rhino Performance Discussions 7 07-23-2008 12:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57