Problems - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-09-2009, 11:06 AM Thread Starter
 
Join Date: Apr 2009
Posts: 15
Problems

I have had nothing but problems with my rhino 700.. I had major problems with it overheating since i got the machine... this past weeknd when i pulled off the hose going into the rad i found the metal tube crimped 90% shut.. it must have came like this from the factory and now i can smell gas in my oil with looks almost like water.. any ideas what to do with this thing.. calling yamaha has gotten me no where .. the bike is only 1 year old!
notes16 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-09-2009, 11:22 AM
1/2 Throttle
 
KJSmith84's Avatar
 
Join Date: Jun 2008
Location: Goodyear, AZ
Posts: 49
blown head gasket - anti freeze getting into your oil i bet.

Cant we all get along? lol
KJSmith84 is offline  
post #3 of 4 (permalink) Old 06-09-2009, 11:28 AM Thread Starter
 
Join Date: Apr 2009
Posts: 15
nice nice..whats that gunna cost me
notes16 is offline  
post #4 of 4 (permalink) Old 06-09-2009, 12:05 PM
1/2 Throttle
 
KJSmith84's Avatar
 
Join Date: Jun 2008
Location: Goodyear, AZ
Posts: 49
Quote:
Originally Posted by notes16 View Post
nice nice..whats that gunna cost me
well if you do it yourself; less then 30 bucks

Cant we all get along? lol
KJSmith84 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gorilla axle problems family wagon Yamaha Rhino General Discussions 18 02-25-2009 08:48 PM
Wet Clutch Problems BrokeUJoint Yamaha Rhino Performance Discussions 6 01-25-2009 09:34 PM
Race Radio Problems BiggJim Yamaha Rhino Electrical Discussions 10 11-12-2008 11:01 PM
Headlight problems loco Yamaha Rhino Electrical Discussions 1 10-16-2008 12:36 AM
My Intake problems Have been solved! vwgti16vt Yamaha Rhino Engine Swap Discussions 5 09-16-2008 01:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58