HELP! Grumbling noise in transmission - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-14-2010, 08:25 PM Thread Starter
1/4 Throttle
 
Join Date: Jan 2010
Posts: 6
HELP! Grumbling noise in transmission

06 660 Rhino
While Rhino is in neutral with the cover off the sheave you can rev it up and let off the gas and the pulleys keep spinning for a long time while making a grumbling noise. Finally when everything quits spinning the noise stops. Belt looks good and is not slipping. What the hell? also the engine brake dosent work anymore

Last edited by fatsy; 03-15-2010 at 08:53 AM. Reason: more info
fatsy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-15-2010, 08:29 AM
Wide F'n Open
 
family wagon's Avatar
 
Join Date: Aug 2008
Location: riverside, C.A.
Posts: 361
It does still spin for a little bit but the noise shouldnt be there. I would pull the sheave off and check the roller and the condition of the sheave also might be the one way bearing in the inner wet cltuch casing...????? not sure just something to check
family wagon is offline  
post #3 of 4 (permalink) Old 03-15-2010, 11:13 AM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Your 1 way bearing on the cluch is bad. You will need to pull it apart and inspect everything...there is a possibility the clutch shaft/drum is also bad. Let me know if you need parts...I got em



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #4 of 4 (permalink) Old 03-15-2010, 12:52 PM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
Quote:
Originally Posted by BiggJim View Post
Your 1 way bearing on the cluch is bad. You will need to pull it apart and inspect everything...there is a possibility the clutch shaft/drum is also bad. Let me know if you need parts...I got em
X2

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58