im stumped - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-08-2010, 11:34 AM Thread Starter
1/4 Throttle
 
Join Date: Apr 2010
Posts: 2
im stumped

Ok, i am having a heck of a time trying to figure out what is wrong with my 2007 660 rhino. I was driving it through a field and it suddenly lost power. It didnt stall right away it just wouldnt pick up speed. I shut it off and now it wont start. it rolls over fine and backfires but wont start. I called a local dealer and he told me that i probably burnt the valves. I tore it down and the valves are fine. The piston is in good shape and the cam looks good. Im trying to put it back together now but dont know how to set the timing. if anyone knows how i would really appreciate some feedback on how to set it. Also if anyone has any ideas about what could be wrong and why it lost its power i would really appreciate any help you could give me.
d1jumper81 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-08-2010, 11:39 AM
Super Moderator
 
mikef's Avatar
 
Join Date: Jun 2008
Location: Inland Empire (Beumont, Ca.)
Posts: 1,068
WOW.... You tore the motor apart without checking the easy obvious stuff first????

1. Clogged fuel filter
2. Bad CDI
3. Air Filter Clogged
Many other things to check before pulling apart the motor.

2006 Rhino 660
BRP Stage 2 CDI
UTVCrap Sheave
4 Seat Cage w/42" Rear PRP Seat
ITP T-7C Wheels (5+2 front offset & 2+5 Rear)
Big Horn Tires (25x8x12 & 25x10x12)
LSR MTS +3 Mid Travel Kit
Bilstein Shocks w/ Eibach Springs 250lb front & 400lb rear
http://i105.photobucket.com/albums/m...BRP_Avatar.jpg http://i105.photobucket.com/albums/m...avatar/byc.jpg http://i105.photobucket.com/albums/m...r/uutv1211.jpg
mikef is offline  
post #3 of 4 (permalink) Old 04-08-2010, 11:42 AM
Wide F'n Open
 
BRMINC's Avatar
 
Join Date: Sep 2008
Location: B-TAOWN
Posts: 263
Pull the gas tank and on the side of the motor where the fan is remove the fan and there is a black threaded plug remove it w. A screw driver and use a flashlight to look in the hole u will see alighnment marks inside line them up by turning the big bolt that was underneath the fan also the cam has 2 dots that need to be horizontal with the head the dots are on the gear down toward the bottom on each side good luck brminc

DUNER
BRMINC is offline  
post #4 of 4 (permalink) Old 04-08-2010, 12:17 PM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Also on the flywheel there are 2 marks...Without looking at the manual I believe TDC is the "I" Mark



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57