660 carb problem? - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-21-2010, 05:19 PM Thread Starter
1/4 Throttle
 
Join Date: Jun 2010
Posts: 2
660 carb problem?

Here is the scoop. have a 06 660 rhino that we keep at a hunting club. Sits up for long periods. Over the last four years it has become harder and harder to crank. After researching decided it must be the fuel pump so we loaded it up and took into to dealer. after three weeks and $350 for a new fuel pump i went to pick it up however would not crank. Another week the have it fixed. claim they installed another fuel pump. i asked if carb was ok they said yes. Unit runs for most of the fall 09 hunting season then quits again around xmas. i figure it has just lost prime. take airbox off put a little fuel on a rag crank and it starts. remove rag it dies. Fuel pump appears to be pumping, fuel filter is clean, all fuel lines are clear. So what is going on here? needle? diaphragm? Need help
crawcrow is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-22-2010, 01:17 PM
Wide F'n Open
 
Benzito's Avatar
 
Join Date: Aug 2009
Location: AZ
Posts: 300
all 660 rhinos r hard to start after they been sitting for over a month, yes they lose prim . keep cranking on it when it dies or keep spraying in the carb keep it going and see if it dies again .

u can buy a brand new hi flow mikuni pump for 59 bucks and it takes 10 minutes to install...

sounds like the dealer ripped u off for 350 bucks for a carb installed? wow stealership 4 sure ...

2007 660 SE - DUAL MUZZY - K&N SET UP - INNOVATE WIDEBAND TUNED - RUGGED RACE RADIO - GEAR ONE RACK -

http://performancetruckproducts.com/

http://www.unleashedutv.com/

http://traillogicllc.com/
Benzito is offline  
post #3 of 5 (permalink) Old 06-30-2010, 01:10 PM Thread Starter
1/4 Throttle
 
Join Date: Jun 2010
Posts: 2
fixed

Put a primer bulb on fuel line to test. Fuel pump is working but no fuel in bowl. tore carburetor down and the needle/floats were glazed from fuel evaporating out of bowl. Put carb back together adjusted idle now purrs like a kitten.
thanks for help
crawcrow is offline  
post #4 of 5 (permalink) Old 06-30-2010, 01:22 PM
Wide F'n Open
 
TURBO's Avatar
 
Join Date: Jun 2008
Location: SOLVANG CA
Posts: 3,313

THERE IS ALWAYS SOMEONE FASTER

BUT ONLY A FEW CAN FLY

TURBO is offline  
post #5 of 5 (permalink) Old 07-07-2010, 05:48 PM
1/4 Throttle
 
Join Date: Jul 2010
Posts: 5
Is the fuel pump located on the engine or is it the mess behind the passenger's seat?
woram67 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
660, carb, fuel pump, stalls

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58