Help ! Rhino wont stay on - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-15-2011, 07:27 PM Thread Starter
Founding Ninja
 
Trooper522's Avatar
 
Join Date: Jun 2008
Location: San Diego
Posts: 1,131
Help ! Rhino wont stay on

Ok guys I need some help. the rhino has been sitting for awhile so I went to go and start it today and it starts with the choke on but but after I let go of the choke it dies. So I went ahead and cleaned the air filter, changed the oil and oil filter, since it was a while since I last changed it. I also put some fresh gas in it and I still have the same problem.

When I let go of the choke I try to keep it going with the gas pedal and it revs up and back fires a little bit.....is this a carb issue ? Please help !!
Trooper522 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-16-2011, 08:59 AM
Wide F'n Open
 
warlock's Avatar
 
Join Date: Jun 2008
Location: Mr. ROTAX
Posts: 1,347
Yeah your carb is plugged up with some varnish. When ever you let gas powered stuff sit for to long now days the shitty fuel starts to varnish up and when it does it plugs carbs up. Same with the generators on toyhaulers they recomend starting and running for ten or so minutes monthly..

2nd place is the first loser!!

Were a whole lot faster than you think you are.
warlock is offline  
post #3 of 4 (permalink) Old 01-16-2011, 01:26 PM Thread Starter
Founding Ninja
 
Trooper522's Avatar
 
Join Date: Jun 2008
Location: San Diego
Posts: 1,131
Thanks Warlock...I was kinda thinking that. I got the carb out but still hanging by the throttle cable which Im thinking Im going to leave on. I can get to the float bowl but those screws are a son of a bitch to remove. Once I got the float bowl off I should be able to get to the jets ? right ?
Trooper522 is offline  
post #4 of 4 (permalink) Old 01-16-2011, 06:28 PM Thread Starter
Founding Ninja
 
Trooper522's Avatar
 
Join Date: Jun 2008
Location: San Diego
Posts: 1,131
Yep it was the carb...small jet plugged up...had to drill out those stupid screws and replaced with alan head metrics purrs like a kitten now
Trooper522 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58