Really bad noise - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-16-2011, 09:40 AM Thread Starter
1/4 Throttle
 
Join Date: Feb 2011
Posts: 4
Really bad noise

I replaced the sheave and weights because that is what i was told was wrong but i am still gettin a bad rattle noise when idle. I noticed the belt was staying engaged also. what would cause this. i am wondering if a new clutch is what i may need
speedy82 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-16-2011, 01:46 PM
1/4 Throttle
 
ranchmkt's Avatar
 
Join Date: Mar 2010
Posts: 25
I don't know much but is the belt still turning at idle? is the idle set to high?if yes and no maybe it is your wet clutch. I would turn down the idle to the lowest setting and see if that works.
ranchmkt is offline  
post #3 of 7 (permalink) Old 02-22-2011, 11:30 AM Thread Starter
1/4 Throttle
 
Join Date: Feb 2011
Posts: 4
im sure it the wet clutch but havent bought it yet will let you know when i do
speedy82 is offline  
post #4 of 7 (permalink) Old 02-25-2011, 09:33 PM
1/4 Throttle
 
USAFAMMO's Avatar
 
Join Date: Jul 2010
Location: Taylorsville, Utah
Posts: 22
Mine was making a horrible sound in the Primary clutch area, and it turned out to be the One way bearing. It's in the wet clutch area...cost about $65 from Benchmark. Fixed my problem. Good Luck!
USAFAMMO is offline  
post #5 of 7 (permalink) Old 02-26-2011, 08:17 AM Thread Starter
1/4 Throttle
 
Join Date: Feb 2011
Posts: 4
did yours sound like a rod knocking.
speedy82 is offline  
post #6 of 7 (permalink) Old 02-26-2011, 12:12 PM
1/4 Throttle
 
USAFAMMO's Avatar
 
Join Date: Jul 2010
Location: Taylorsville, Utah
Posts: 22
No, didn't have a knocking sound, more of a shrill roar, also had no engine braking.
USAFAMMO is offline  
post #7 of 7 (permalink) Old 04-01-2011, 01:05 PM
1/4 Throttle
 
Join Date: Apr 2011
Posts: 2
my 07 has a knocking noise heard it may be 2 peice crank dont know
rocket63 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58