Starting and idle issues - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-25-2011, 01:19 PM Thread Starter
1/4 Throttle
 
Join Date: Jun 2011
Location: Cocoa, FL.
Posts: 2
Starting and idle issues

Hello; I have an issue with a 07 rhino 660 carbed engine. It is very hard to start, in fact will not start without a lil throttle. I can then increased the rpms with the idle speed adjuster"thumbwheel" to keep engine running. after about 5 mins. of this I can then turn down the rpms to a slow enough idle to be able to shift gears. I have to repeat this every start even when warm. it seems like the ignition cuts right out when I idle it down before its hot.

So far I have replaced fuel pump and filter, swapped cdi's, cleaned all grounds, drained and cleaned out fuel tank, took float bowl off of carb and cleaned all three jets, checked all intake boots and vac. lines for leaks, tried pressurizing the tank through the vent to prime the pump, changed spark plug, cleaned air filter.

Choke cable is not bound up and choke does not help starting.

I do notice that my clear fuel filter is not filling up with fuel completely, when warmed up the engine runs fine and does not seem to starve for fuel.

What am I missing??????????
fl-wingnut is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-25-2011, 09:27 PM
Wide F'n Open
 
Join Date: Aug 2009
Posts: 158
Replace the fuel filter. Run some carburetor cleaner through the carb, then dump a bottle of Lucas fuel system treatment through it. Sounds like the carb is pretty dirty and given the crappy gas that's being forced upon us its not surprising to be having carb problems.

I know my 2008 Yamaha Grizzly 450 was really bad trying to keep running sometimes and I ended up having to clean the carb and run fuel system cleaner through it quite a bit.
wildbill23c is offline  
post #3 of 5 (permalink) Old 08-03-2011, 11:53 PM
1/4 Throttle
 
Join Date: Jun 2011
Posts: 16
first of all, you need to replace the fuel filter. it is very important
MJsusan is offline  
post #4 of 5 (permalink) Old 11-30-2011, 12:56 PM
1/4 Throttle
 
Charger's Avatar
 
Join Date: Nov 2009
Posts: 29
If the choke does not seem to make a difference, take it loose at the carb and pop it out and give it a good cleaning. It works off of vaccum so you might give it a once over for a vaccum leak. Carefully, spray some WD-40 around the intake boots and see if it raises the rpm.

I have also had problems with the fuel filter stopping up from time to time with something that looks like silicone. Seems to be something coming loose in the fuel tank and being picked up in the fuel. Take a very close look at the filter for small foreign crud. I bypassed the stocker and put an inline filter where it comes out of the tank and is easier to see. Even with an electric pump, my filter does not run full.

Last edited by Charger; 11-30-2011 at 01:03 PM.
Charger is offline  
post #5 of 5 (permalink) Old 12-08-2011, 06:34 PM
1/4 Throttle
 
Join Date: Jul 2011
Posts: 2
Adjusting my valves made a huge difference in start-up on my 07
newdoo is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58