Basic fuel pump question - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-01-2012, 04:14 AM Thread Starter
1/4 Throttle
 
Join Date: Mar 2012
Posts: 3
Basic fuel pump question

I have a 2006 660 Rino. I'm not a mechanic and only have a little practicle knowlege. Last week I was antler hunting and went down a steep incline road into a deep canyon. Say I was about 2 minutes going downhill slow using the engine to hold me back while beaking intermittenly. Lost fuel. Filter seemed to be working fine. Checked all the lines and when I examined the fuel pump noticed no electricle connections. Figured it must work off vacuum.

I jerry rigged a gravity feed system to get out and I was riding the pump began to work fine. I've had no problems since. Is there a potential problem in the future? Did my downhill ascent cause this and is there something I can do to prevent this happening? Thanks for any insight!
Barryhoff is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-01-2012, 06:39 PM
1/4 Throttle
 
Join Date: Mar 2012
Posts: 12
I just had a similar issue, not with mine but with a friend's 2007 660. We let it sit on a down hill incline while swimming in the creek, then after 45 minutes started her up, and after the carb ran out of fuel she died. Ended up towing it back. Saw no fuel coming from fuel pump, took it apart at camp, saw nothing wrong, looked great, fuel in filter, fuel flowing easy from tank. Put it all back together and feed her a little direct fuel to get it running, and the fuel pump started working again, seemed fine the rest of the weekend? Seems like the incline wasn't good???
jdshort98 is offline  
post #3 of 6 (permalink) Old 04-01-2012, 09:51 PM Thread Starter
1/4 Throttle
 
Join Date: Mar 2012
Posts: 3
Exactly! I just want to be sure it's not fuel pump failure but something to watch for when I go out!
Barryhoff is offline  
post #4 of 6 (permalink) Old 07-21-2013, 02:56 PM
1/4 Throttle
 
Join Date: Sep 2012
Location: East Helena, MT
Posts: 4
fuel pump?

Quote:
Originally Posted by Barryhoff View Post
Exactly! I just want to be sure it's not fuel pump failure but something to watch for when I go out!
I just had the same thing happen to me. Going down hill and the motor in my '07 660 just died. I tried to start it, and it would die as soon as the choke was pushed in. That is until it wouldn't start at all. So what is the story?
MTMark is offline  
post #5 of 6 (permalink) Old 07-28-2013, 08:04 PM
1/4 Throttle
 
Join Date: Jul 2013
Location: Laveen AZ
Posts: 3
Carburators do that when the road is too steep. Fuel injection does not have that problem. Unless you have a pumper carb like in a chain saw the float bowl can get dry or the pick up point in the gas tank needs to have a tube with a weight on it to go to the bottom of tank. Nothing wrong with your fuel pump
bushpilot is offline  
post #6 of 6 (permalink) Old 07-28-2013, 09:40 PM
1/4 Throttle
 
Join Date: Sep 2012
Location: East Helena, MT
Posts: 4
Fuel pump?

Quote:
Originally Posted by MTMark View Post
I just had the same thing happen to me. Going down hill and the motor in my '07 660 just died. I tried to start it, and it would die as soon as the choke was pushed in. That is until it wouldn't start at all. So what is the story?
-------it was the fuel filter! Should be changed during major servicing.
MTMark is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58