Rhino won't crank please help!! - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-07-2012, 09:56 PM Thread Starter
1/4 Throttle
 
Join Date: Apr 2012
Location: Hartsville, South Carolina
Posts: 10
Rhino won't crank please help!!

So I bought a used rhino a few months ago and it has been totally fine mechanically up till now. I gave it a pretty good beating over the past few days but was still running ok. Tonight I cranked it up and drove maybe 300 yards very smoothly and under 15mph nothing crazy. I got out to do some work and when I got back in it wouldn't start. I tried everything. It makes this almost grinding sound and won't crank. Battery is good has gas all that. Sounds like a bad starter. Like the starter is stripped. Please help. Any ideas?
W321shark is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-08-2012, 02:21 PM
1/4 Throttle
 
Join Date: Mar 2012
Posts: 7
Quote:
Originally Posted by W321shark View Post
So I bought a used rhino a few months ago and it has been totally fine mechanically up till now. I gave it a pretty good beating over the past few days but was still running ok. Tonight I cranked it up and drove maybe 300 yards very smoothly and under 15mph nothing crazy. I got out to do some work and when I got back in it wouldn't start. I tried everything. It makes this almost grinding sound and won't crank. Battery is good has gas all that. Sounds like a bad starter. Like the starter is stripped. Please help. Any ideas?
Where is the grinding noise coming from?
RowdyRhinoceros is offline  
post #3 of 4 (permalink) Old 06-08-2012, 08:33 PM Thread Starter
1/4 Throttle
 
Join Date: Apr 2012
Location: Hartsville, South Carolina
Posts: 10
It turned out to be the starter clutch. Couldn't figure it out and broke down and took it to the yamaha dealer near me. The guy ran the vin and it turned out to have a extended warrenty on it and they fixed it all for free that was a relief
W321shark is offline  
post #4 of 4 (permalink) Old 06-09-2012, 11:43 AM
1/4 Throttle
 
Join Date: Mar 2012
Posts: 7
Quote:
Originally Posted by W321shark View Post
It turned out to be the starter clutch. Couldn't figure it out and broke down and took it to the yamaha dealer near me. The guy ran the vin and it turned out to have a extended warrenty on it and they fixed it all for free that was a relief
Cool, good news!
RowdyRhinoceros is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
bad starter, rhino, utv, won't crank, won't start

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57