Timing issue, center intake valve keeps breaking off - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-13-2012, 11:39 AM Thread Starter
1/4 Throttle
 
Join Date: May 2010
Location: Mesa, Az
Posts: 7
Angry Timing issue, center intake valve keeps breaking off

Any ideas anyone ? I have a 2005 Rhino 660, After a complete top end engine rebuild I have had problems with the center intake valve. I have replaced it three times now. Engine runs fine after initial replacement then when i take out to riding area the valve breaks within 10-15 minutes ride time. The issue is the piston is making contact with the valve. First two times it broke I was at full throttle, this time I was at about 50% throttle when it broke. All alignment marks are correct for the cam gear, cam and decompresion springs. I just replaced the timing chain and installed NEW 700 chain tensioner on most recent rebuild. I'm at a loss for what going on. The cam is a Hot cam installed by a previous owner. I have had Weller Racing look at the cam, head and valves and they have supplied the parts and done the machine work. Is it possible that the pin inside the cam that contact the center valve isnt working properly ? Somehow this thing is going out of timing. When I disable the motor the timing alignment marks are still correct. There is no damage to the pistion just a little mark where the valve made contact. Any ideas anyone ?
atvhigh is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-18-2012, 03:38 AM
1/4 Throttle
 
Join Date: Jun 2012
Posts: 15
I think it is best to see a really good mechanic and get a proper diagnosis of the problem. Timing problems are intricate and would require precise solutions. Trial and error won't solve it. Just my $0.02
TScott27 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57