Sheave Clunk on decel - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-17-2013, 06:53 AM Thread Starter
1/4 Throttle
 
Join Date: Mar 2012
Posts: 12
Sheave Clunk on decel

I have a 2008 700 Rhino that I bought used. What a mistake!! This bike was rode hard and put up wet. The last problem I found I could use some help with, I am new to CVT's and might have made a mistake. I was riding the bike and the belt cooked out, white smoke everywhere. Well I had a spare so got towed back to camp and took the belt cover off only to find the belt cooked but also the fixed primary sheave splines stripped out. And the reason, who ever was in there last left the squirrel cage off, the cage that holds the primary shaft steady. So i assume that's what caused the failure. I also found the teflon material of the sliders melted, as well as the plastic sliders that hold the cam plate in place. So I ordered a new belt, new primary sheave complete, the fixed plate, the housing and weights and cam plate etc. I watched a UTV crap video and greased the weights like the video showed, even though I bought all OEM parts. Put it back together and it rides great, but I notice a clunk after a harder accell then decel. Sounds to me like the weights could be over greased and makes the roll back delayed? Or could there be something else I did wrong, or something in the wet clutch wrong? I didn't take it apart. Please help!!
jdshort98 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-13-2013, 02:33 PM
1/4 Throttle
 
Coops clutch mods's Avatar
 
Join Date: Apr 2013
Location: Utah
Posts: 9
More than likely it is drive line lash, shaft to gear box, very normal.
Coop45
Coops clutch mods is offline  
post #3 of 3 (permalink) Old 12-21-2014, 08:35 PM
1/4 Throttle
 
Join Date: Dec 2014
Posts: 1
Hey coop how do you go about fixing this problem. My 2008 700 is having this issue on decelerating. It doesn't do it when reversing though and if I have my friend ride in the back bed his weight seems to quite or eliminate the noise. Thanks
termiteman is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Tags
2008, 700, clutch, grease, sheave

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58