Grinding noise while pressing on brake pedal! - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino General Discussions General discussions pertaining to the Yamaha Rhino.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-28-2013, 08:06 PM Thread Starter
1/4 Throttle
 
Join Date: May 2013
Posts: 2
Grinding noise while pressing on brake pedal!

Hello all new to this site and new to owning a rhino. The noise is really noticeable while going down steep hills while pressing on the the brakes. My rhino is a 2007 660 with 800 miles on it. I was hoping it was just the brakes were worn out but checked all of them and are like new. Not sure if someone else has had this problem. Also could it be something with the clutch maybe or maybe just really glazed brake pads.
Sandalland is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-11-2013, 10:08 AM
1/4 Throttle
 
Join Date: Jun 2013
Posts: 1
Its a bad design . my 660 rear brake was always dragging and making that horrible sound.They put it on the drive shaft and made it a rear brake/ parking brake. I went through pads so fast i took it off. The newer ones i have are disk on all 4 plus the e brake on driveshaft . Its just something you will have to deal with or take off.
hornedone is offline  
post #3 of 4 (permalink) Old 09-08-2013, 08:07 PM
1/4 Throttle
 
SARDAWG's Avatar
 
Join Date: Sep 2008
Posts: 5
The stock brake pads will "glaze" especially if the unit was driven with the parking brake on. Take off the pads and sand them with 60 grit sandpaper and in my case it stopped the noise doing the same as you describe.

So den the guys says "Why Me?"
SARDAWG is offline  
post #4 of 4 (permalink) Old 09-17-2013, 09:57 AM
1/4 Throttle
 
Join Date: Sep 2013
Posts: 2
I recently ran into the same issue. I checked the pads also and all seemed well until I disassembled the rear brakes. The pad was completely worn off and it was metal on metal. Replaced with some cheap pads off eBay for like 8 bucks and its all good now.
Noble is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57