06 660 tops out 33mph and pops sometime - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 35 (permalink) Old 11-30-2008, 10:53 PM Thread Starter
 
Join Date: Nov 2008
Posts: 36
06 660 tops out 33mph and pops sometime

went out for turkey day and i couldnt get over 33 going down a flat wash and sometimes would back fire when going through whoops getting on and off the gas.
crfnick is offline  
Sponsored Links
Advertisement
 
post #2 of 35 (permalink) Old 11-30-2008, 11:00 PM
Wide F'n Open
 
warlock's Avatar
 
Join Date: Jun 2008
Location: Mr. ROTAX
Posts: 1,347
Check your fuel filter. actually just replace it now anyhow.

2nd place is the first loser!!

Were a whole lot faster than you think you are.
warlock is offline  
post #3 of 35 (permalink) Old 11-30-2008, 11:14 PM Thread Starter
 
Join Date: Nov 2008
Posts: 36
ya i am going to replace that, but i didnt know if maybe it could be from valves out of adjusstment or the timing or even just the belt wearing out.
crfnick is offline  
 
post #4 of 35 (permalink) Old 12-01-2008, 08:23 AM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
33mph top speed sure sounds like a fuel filter. Not that I think it is the cause but have you ever adjusted the valves?

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
post #5 of 35 (permalink) Old 12-01-2008, 08:57 AM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Backfiring....could be a fuel issue. Check all you lines for cracks, and fuel filter. I would start there



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #6 of 35 (permalink) Old 12-01-2008, 05:34 PM
Wide F'n Open
 
trestles126's Avatar
 
Join Date: Aug 2008
Posts: 214
gaurentee its the reverse rev limiter coming on I had to ground out my reverse sensor mine did the same exact thing last year 33 miles an hour the sensor for the reverse (even though you are in High gear) senses for some rearson its in reverse and it puts the rev limiter on I can get you pics of what the wire looks like its on the passenger side in the wire loom you pull it from the quick connect wire fittin about half way down the wire has a rubber boot on it. and ground it out and its fixed. Not sure of the right way to fix it all it does is make i so your reverse R doesnt show up when you have it in reverse on the digi dash...sorry for the horrible explanation but im pretty positive thats your problem...mine showed the same symptons on a poker run last thanksgiving
trestles126 is offline  
post #7 of 35 (permalink) Old 12-01-2008, 05:39 PM
Wide F'n Open
 
trestles126's Avatar
 
Join Date: Aug 2008
Posts: 214
sorry i forgot that the R light on the digi dash used to flash as well does your do that when having the problem?
trestles126 is offline  
post #8 of 35 (permalink) Old 12-01-2008, 07:19 PM
Wide F'n Open
 
pronstar's Avatar
 
Join Date: Jun 2008
Location: The LBC
Posts: 256
My "R" lights comes and goes but doesn't limit my speed.

I do get popping occasionally, and for me it's always a clogged outerwear on my air filter. Once clean, problem solved.

'07 Rhino 660 * Mason LT * Elka Elites * Ron Woods exhaust * 38.2 hp on the Pro Shop's Dyno * LiveWire Whip
pronstar is offline  
post #9 of 35 (permalink) Old 12-01-2008, 07:24 PM
Wreckin' Shop
 
BiggJim's Avatar
 
Join Date: Jun 2008
Location: B-Town foooooo
Posts: 5,385
Quote:
Originally Posted by trestles126 View Post
gaurentee its the reverse rev limiter coming on I had to ground out my reverse sensor mine did the same exact thing last year 33 miles an hour the sensor for the reverse (even though you are in High gear) senses for some rearson its in reverse and it puts the rev limiter on I can get you pics of what the wire looks like its on the passenger side in the wire loom you pull it from the quick connect wire fittin about half way down the wire has a rubber boot on it. and ground it out and its fixed. Not sure of the right way to fix it all it does is make i so your reverse R doesnt show up when you have it in reverse on the digi dash...sorry for the horrible explanation but im pretty positive thats your problem...mine showed the same symptons on a poker run last thanksgiving
Very well could be the problem.........No offence but that is a half ass way to fix it. If thats the problem its the sensor and they are about 16 bucks fro m the stealership



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

BOOYAA

Juggstalk.net.....because we dont sell phone no MO!!
BiggJim is offline  
post #10 of 35 (permalink) Old 12-01-2008, 07:55 PM
Wide F'n Open
 
trestles126's Avatar
 
Join Date: Aug 2008
Posts: 214
ya i agree but it went bad after about 60 miles on the rhino and it really sucked gettin halfway on a 100 mile ride and having to put it back at 33 miles an hour!!! figure i wont give the switch another change to go bad
trestles126 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58