My rhino stalls out sometimes. - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools
Old 06-01-2009, 08:19 AM Thread Starter
1/4 Throttle
 
Join Date: Jun 2009
Posts: 8
My rhino stalls out sometimes.

Hello my name is Mike and I live in Puerto Vallarta. I hope this is the right place to ask this question. I searched for a thread with the same problem, but couldn't find one.

I have '97 Rhino. It is far from stock as the previous owner did a lot of high performance things to the engine. This rhino goes 53 mph now. I am not very mechanically enclined so i can't really tell you exactly what was done to the engine at this point, but i can find out if it is of major importance.

So here is what happened. Yesterday I went to the river. It takes about 1 hour to get there. There were no issues on the trip there. After arriving my wife and I relaxed in the river for about 2 hours. Then we got back in the rhino and headed to the next restaurant about 30 mins further up the river. Everything was fine till just before we arrived there and it started to stall out as if it wasn't getting enough gas. So I let it sit for 5 mins. and choked it and it started right up again it ran for about 10 mins without problems then again sputtered and died.

I had these problems off and on for the next hour. Then it finally ran well again for about 45 mins. Then again sputtered and died many times acting as if it isn't getting enough gas.

The previous owner told me that I have to hold the choke out for atleast 30 secs-1 min. when starting it cold so I have been doing that. Also, to finally get it home I had to hold the choke about 1/4 of the way out to keep it running. Has anyone else had a problem like this? If so, how did you fix it or what do you think i need to do to fix it?

I really wish this thing didn't have so many modifications to the engine. I have rented stock rhinos many time before and never had this problem once after driving them all day.

Thanks in advance for any help.


Mike
mwh72 is offline  
Sponsored Links
Advertisement
 
Old 06-01-2009, 08:21 AM
Red Cup Ninja
 
shonuff's Avatar
 
Join Date: Jun 2008
Location: murrieta,ca
Posts: 3,312
you mean 07 rhino right?

i would start with replacing the gas filter.

welcome to rhinotalk!

Fuck'em and feed'em cabbageI have found the richer your friends are.....the more they want you to suck their asses.......I guess these fools havent figured out yet I dont suck ass ~ the bigg anonymous
shonuff is offline  
Old 06-01-2009, 08:27 AM Thread Starter
1/4 Throttle
 
Join Date: Jun 2009
Posts: 8
Quote:
Originally Posted by shonuff View Post
you mean 07 rhino right?

i would start with replacing the gas filter.

welcome to rhinotalk!

Oops yeah it's 2007. I don't know why I put '97, duh. So this sounds like a gas filter problem well that is great news if it is. I will find out when was the last time it was changed.
mwh72 is offline  
 
Old 06-01-2009, 08:50 AM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
definetly sounds like a filter problem.
time shouldn't matter on the filter, it can go bad after ten minutes if the right crude is in your lines,you should learn how to change it and always carry a spare

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
Old 06-03-2009, 12:20 PM Thread Starter
1/4 Throttle
 
Join Date: Jun 2009
Posts: 8
Looks like it was the fuel injector. Being replaced as I type. Will update later.
mwh72 is offline  
Old 06-03-2009, 01:29 PM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
Quote:
Originally Posted by mwh72 View Post
Looks like it was the fuel injector. Being replaced as I type. Will update later.
Not on an 07.

FI is 2008 an newer


07 and older is Carb'ed

maybe your it was the fuel pump



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
Old 06-03-2009, 01:32 PM
Wide F'n Open
 
Powerplay's Avatar
 
Join Date: Aug 2008
Location: your moms house
Posts: 2,107
might be a muffler bearing..

Ninja police ????Y Hope you Got a Ninja warrant.... ...
Powerplay is offline  
Old 06-03-2009, 02:26 PM Thread Starter
1/4 Throttle
 
Join Date: Jun 2009
Posts: 8
Quote:
Originally Posted by 07fj View Post
Not on an 07.

FI is 2008 an newer


07 and older is Carb'ed

maybe your it was the fuel pump
Yes, you are right it was fuel pump. My spanish isn't perfect and the mechanic doesn't speak english. Going to go and pick up my rhino in 30 mins. Hopefully all goes well.
mwh72 is offline  
Old 06-03-2009, 02:38 PM
Wide F'n Open
 
Powerplay's Avatar
 
Join Date: Aug 2008
Location: your moms house
Posts: 2,107
hook a donkey up to that bad boy you be rollin dirty fo sho !

Ninja police ????Y Hope you Got a Ninja warrant.... ...
Powerplay is offline  
Old 06-03-2009, 03:13 PM
RhinoTalk.net Site Sponsor
 
Bryan M's Avatar
 
Join Date: Jun 2008
Location: ummmmmm Im not sure..fuck, I think were lost!
Posts: 1,377
Quote:
Originally Posted by Powerplay View Post
might be a muffler bearing..

just replaced mine.....runs waaaaaay better!








If you live in Vegas and need a General Contractor...call Manning Construction @ 497-5127
Bryan M is offline  
Sponsored Links
Advertisement
 
 

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57