engine miss at high rpm - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 07-23-2009, 09:53 PM Thread Starter
3/4 Throttle
 
Join Date: Jul 2009
Location: arkansas
Posts: 53
engine miss at high rpm

have an 07 rhino motor is stock. i am running a k&n filter,big gun exhaust,carb has been jetted,cdi box. rhino starts and idles like a champ but as u get 2 bout 40mph it will sputtr. it is really noticable n the neutral position or goin down hill. motor has 1600 miles on it. oil gets changed every 300 miles with filter spark plug is factory ngk and changed every 500 miles but is usually burnt pretty bad.fuel filter every 500 miles. tore carb down yesterday and is spotless.any suggestions on what 2 check next. run cheap gas is high octane gas betr or what about running seafoam 4 fuel treatment. oh yeah the sputr will not kill the motor just enouh 2 piss u of.
jonboy84 is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 07-23-2009, 10:06 PM
RhinoTalk.net Site Sponsor
 
Hapa's Avatar
 
Join Date: Jun 2008
Location: OC
Posts: 7,197
isnt the 07 efi? if its carbureted i would say cdi or maybe just needs a fuel controller,,maybe fuel pump? I am guessing here

Benchmark Performance 760-484-0986
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
BYC Motorsports
Hapa is offline  
post #3 of 20 (permalink) Old 07-23-2009, 10:18 PM Thread Starter
3/4 Throttle
 
Join Date: Jul 2009
Location: arkansas
Posts: 53
gona put stock cdi back on n the morning and give it a try.is there a way 2 check fuel pump?
jonboy84 is offline  
 
post #4 of 20 (permalink) Old 07-23-2009, 10:31 PM
RhinoTalk.net Site Sponsor
 
Hapa's Avatar
 
Join Date: Jun 2008
Location: OC
Posts: 7,197
Quote:
Originally Posted by jonboy84 View Post
gona put stock cdi back on n the morning and give it a try.is there a way 2 check fuel pump?
I dont know a good test, do eveything else first? some cdi's came from the maufacturer not working right...I got a bad one and had a hell of a time figuring it out because I did a bunch of stuff at once.. didnt know which upgrade caused the problem, I also have a new fuel pump on there lol

Benchmark Performance 760-484-0986
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
BYC Motorsports
Hapa is offline  
post #5 of 20 (permalink) Old 07-23-2009, 10:39 PM Thread Starter
3/4 Throttle
 
Join Date: Jul 2009
Location: arkansas
Posts: 53
Quote:
Originally Posted by Hapa View Post
I dont know a good test, do eveything else first? some cdi's came from the maufacturer not working right...I got a bad one and had a hell of a time figuring it out because I did a bunch of stuff at once.. didnt know which upgrade caused the problem, I also have a new fuel pump on there lol
if cdi is bad this will b the 3rd box. 1st 2 boxes didnt make it a month this 1 has lasted awhile. if i do change out pump go back with factory pump or aftr market?
jonboy84 is offline  
post #6 of 20 (permalink) Old 07-23-2009, 10:45 PM
RhinoTalk.net Site Sponsor
 
Hapa's Avatar
 
Join Date: Jun 2008
Location: OC
Posts: 7,197
the fuel pump discussion went down on utvunderground and they decided a stock was all you need.. i had already got a high flow pump from a vendor in Glamis, It was all he had and it works great, noticeable improvement from the first ride.

Benchmark Performance 760-484-0986
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
BYC Motorsports
Hapa is offline  
post #7 of 20 (permalink) Old 07-24-2009, 01:36 PM Thread Starter
3/4 Throttle
 
Join Date: Jul 2009
Location: arkansas
Posts: 53
not the cdi box put stock one back on still sputtrs at middle to high rpms. gona put stock jet back in and c what happens. thanks for the input so far.
jonboy84 is offline  
post #8 of 20 (permalink) Old 07-24-2009, 01:40 PM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
check all of the boots connecting the carb for tears or holes, check your exhausts for leaks at all connections.
and run min of 91 octane

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
post #9 of 20 (permalink) Old 07-24-2009, 01:44 PM Thread Starter
3/4 Throttle
 
Join Date: Jul 2009
Location: arkansas
Posts: 53
10-4 will do
jonboy84 is offline  
post #10 of 20 (permalink) Old 07-24-2009, 01:57 PM Thread Starter
3/4 Throttle
 
Join Date: Jul 2009
Location: arkansas
Posts: 53
found a hole on uderside of the slip on exhaust. the hole is rite after where the 2 pipes connect is this supposed to b there and if not is it fixable and whats best way 2 fix.
jonboy84 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58