2005 660 Rhino With Problem - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-20-2009, 02:32 AM Thread Starter
1/4 Throttle
 
Join Date: Sep 2009
Location: West Virginia
Posts: 3
2005 660 Rhino With Problem

I have a 2005 660 Rhino that has problems. I put on a new dynatek cdi and coil thinking it would fix my problem. When my Rhino reach's operating temperature. It stops running and wont start. It does the same with the new cdi. Also the speedometer is messed up now.Showing higher speed then the actual speed. I purchased this rhino used. It had 400 hours on it. It has been a money pit from day one. I have replaced the cooling fan switch also. Replaced fuel pump and filter. Yamaha shop adjusted valves also. Replaced all wheel bearing, Had to have rear diff, frame wielded and purchase aftermarket rear frame support for diff. I hate to sell it. to much invested to sell. Unit had $10,000.00 in accessories when purchased. I have never rode one trip with out it breaking down and ruining everyone's day. Does anyone have any sugguestions ?
Rich is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57