660 Rhino Not Running Well. - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-18-2009, 01:48 PM Thread Starter
1/4 Throttle
 
Join Date: Oct 2009
Posts: 1
660 Rhino Not Running Well.

My 660 Rhino is having some trouble. It starts up and idles fine, however when you give it a little gas it cuts out... even after letting it warm up properly.

I have drained the fuel tank thinking bad fuel was the problem, also tried bypassing the fuel filter thinking it may be too dirty... but neither fixed the issue.

Thinking it may be the fuel pump? Have not checked the plug. Any help would be great.

Thanks,

Jack
Bud Dieselman is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-18-2009, 02:53 PM
Wide F'n Open
 
dbansheebob's Avatar
 
Join Date: Jun 2008
Location: Hesperia, CA
Posts: 297
Try cleaning the jets in the carb.
dbansheebob is offline  
post #3 of 10 (permalink) Old 11-12-2009, 03:39 PM
1/4 Throttle
 
Join Date: Feb 2009
Posts: 8
I had problems with mine doing the same thing and at WOT it would just run out of fuel and die. Crank for a short bit and it would fire and go again. I changed filters, checked hoses, tore the carb down to check and clean but still had the same problem. Finally checked the output on the factory fuel pump and found it to be very weak. Changed to the high output Mikuni fuel pump and problem was solved. Only reason I went with the HO pump over factory is that the cost was less than a Yamaha pump. Bought online from Cape Fear Motorsports - Watercraft Parts and Accessories for $42 and all was fine.
gregnamy is offline  
 
post #4 of 10 (permalink) Old 04-27-2010, 10:40 PM
1/4 Throttle
 
Join Date: Apr 2010
Posts: 5
Hi flo fuel pump

WE HAVE AN '07 660 ....AFTER AROUND 90 HRS....SAME DANG THING....UNDERLOAD...IT WOULD BACKFIRE AND COME TO A STOP...CHECKED EVERYTHING YOU ALL DID, STILL UNDER WARRANTY, TOOK TO YAMAHA DEALERS ONE COULDNT FIND ANTHING WRONG, THE OTHER CHARGED ME $180 AND CLAIMED IT WAS FIXED....UNLOADED AT HOME....WHENT APPROX 100 FT, AND SAME SENERIO ....BUDDY OF OURS TOOK IT HOME FOR A WEEK, TORE THE FUEL SYSTEM COMPLETELY DOWN....FOUND A BEETLE BUG THAT WAS GETTING SUCKED UP TO THE FUEL FILTER AND ACTING AS A CHECK BALL EFFECT....WHEN ENGINE DIED, BUG WOULD SINK BACK DOWN THE HOSE...YEAR LATER HERE WE GO AGAIN, THOUGH NO BUG,,,PUMP IS NOT FLOWING....SO THINKING ABOUT THE MUKUNI, WHAT DID YOU DO W/ THE EXTRA OUTPUT??
saddlemt is offline  
post #5 of 10 (permalink) Old 04-27-2010, 11:03 PM
Wide F'n Open
 
Benzito's Avatar
 
Join Date: Aug 2009
Location: AZ
Posts: 300
u can just cap the extra output or dual line it into a T into 1 main

get the clear fuel line kit to

2007 660 SE - DUAL MUZZY - K&N SET UP - INNOVATE WIDEBAND TUNED - RUGGED RACE RADIO - GEAR ONE RACK -

http://performancetruckproducts.com/

http://www.unleashedutv.com/

http://traillogicllc.com/
Benzito is offline  
post #6 of 10 (permalink) Old 04-28-2010, 02:58 AM
1/4 Throttle
 
Join Date: Feb 2009
Posts: 8
Smile

Saddlemt, I just plugged off the extra output and in addition installed one of those larger see through gas filters from an auto parts store so that I could see the fuel flow. I also found out the hard way that if your machine sits around for extended lengths of time with out being run the fuel will dry up in the bowl and carb systems and varnish over. After talking with several of the local dealerships they said this is common with gasoline in our area and that it can happen in a number of weeks. I have since started using gas Stabilizer if I know I won't be riding much which is typical in the summer time. So you may want to tear the carb down completely and check all of the passage ways and seats, the smallest amount of junk will give you fits. Another thing I started doing is to use a funnel with a screen on it when filling the gas tank. For whatever reason I have found debris in my gas cans on occasion (same ones I use for the mower and everything else around the house that requires gas) that will end up in your tank and be a pain to remove. Good luck and I hope it solves your problem.
gregnamy is offline  
post #7 of 10 (permalink) Old 04-28-2010, 02:51 PM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
Quote:
Originally Posted by Bud Dieselman View Post
My 660 Rhino is having some trouble. It starts up and idles fine, however when you give it a little gas it cuts out... even after letting it warm up properly.

I have drained the fuel tank thinking bad fuel was the problem, also tried bypassing the fuel filter thinking it may be too dirty... but neither fixed the issue.

Thinking it may be the fuel pump? Have not checked the plug. Any help would be great.

Thanks,

Jack

will it cough if you pull the choke out a little? if not, readjust your mix screw on bottom of bowl, about 1 3/4 out.



a couple things can cause this, vacuum leak, torn carb diaphram on top of carb, dirty jets as mentioned, fuel filter/line plugging in pickup, and lastly weak pump.

if it sets for a while, it can be hard starting as stated also, takes a while to prime the pump again and fill the Carb bowl. when started let sit while running for a while to make sure bowl gets filled up, before taking off.


Rog



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
post #8 of 10 (permalink) Old 05-18-2010, 04:59 PM
1/4 Throttle
 
Join Date: Apr 2010
Posts: 5
finally rcvd the fuel pump we ordered from cape fear.....runs better now then it did new??? (it seems to idle better?) i'm not gong to complain about it though & i did add a second see thru filter also as you did for future trouble shoot'n (as we use this for hunting, sometimes 20-40 miles from home camp) thanks again for the help!! now i have to sorce a right rear axle assy. as it has gone bad also, i understand that is commin on '07 models too (& yamaha fixed on the 700 efi models) funny how this all happens weeks after my purchased extended warranty is up, still have under 200 hrs. hope thats it for awhile, i thought these where the most reliable suv's when i researched them before buying??? thanks again for the help everyone!!!
saddlemt is offline  
post #9 of 10 (permalink) Old 05-18-2010, 05:04 PM
Founding Ninja
 
07fj's Avatar
 
Join Date: Jun 2008
Location: ramona, ca
Posts: 3,156
call BYC Motorsports for an axle assy ask for Jimmy 714-553-5248

of factory ones from Benchmark performance 760-484-0986 Ask for Chris


Rog



Benchmark Performance 686, 67.6 RWHP
http://www.unleashedutv.com/ 602-246-4011
Rigid Industries 480.655.0100
07fj is offline  
post #10 of 10 (permalink) Old 05-19-2010, 12:48 PM
1/4 Throttle
 
Join Date: Apr 2010
Posts: 5
Ok thanks ROG!! Sorry about the duplicate post on gen. discussions!!!!!
saddlemt is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57