BOGS in reverse - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-09-2010, 07:40 PM Thread Starter
 
Join Date: Jan 2010
Posts: 3
BOGS in reverse

OK, new to the forum. I am hoping that I can get some answers. I have a 07 660 that I use around my ranch. I use it to plow, haul and other jobs. Just recently my rhino has begun to run poorly in reverse. No power, spits and sputters. It has cause me to get stuck several times while plowing. I have noticed that my speedometer works intermittently. When it works I can back up with all the power I need, but when it is not functioning and the reverse light is blinking then I have no power. I have been told that it is my CDI. I have also been told it is the speed sensor. Can anyone give my better info. I put new plug, fuel filter, and some yamaha ringless cleaner in it as a rule out. No change.
Firemedic is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-10-2010, 05:39 AM
RhinoTalk.net Site Sponsor
 
max powers's Avatar
 
Join Date: Jun 2008
Posts: 2,988
Quote:
Originally Posted by Firemedic View Post
OK, new to the forum. I am hoping that I can get some answers. I have a 07 660 that I use around my ranch. I use it to plow, haul and other jobs. Just recently my rhino has begun to run poorly in reverse. No power, spits and sputters. It has cause me to get stuck several times while plowing. I have noticed that my speedometer works intermittently. When it works I can back up with all the power I need, but when it is not functioning and the reverse light is blinking then I have no power. I have been told that it is my CDI. I have also been told it is the speed sensor. Can anyone give my better info. I put new plug, fuel filter, and some yamaha ringless cleaner in it as a rule out. No change.
bad cdi

VictoryGardenshydro.com
WeedConnect.net,get connected
max powers is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58