Hard to get started - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-10-2010, 10:55 PM Thread Starter
1/4 Throttle
 
Join Date: Jan 2010
Posts: 5
Hard to get started

I have an 07 Rhino 660!! When it sits for a while and has not been run it is takes some cranking to get started!! It turns over for a while until the battery is almost out of juice then it will fire off!! After its started it runs great!! It can even sit for a day or two and it will start with ease!! But when I leave and return to my hunting camp after a few weeks of sitting it happens!! What could this be? I changed the fuel filter!! Maybe the plug next?
droptine is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-11-2010, 12:01 AM
Wide F'n Open
 
Benzito's Avatar
 
Join Date: Aug 2009
Location: AZ
Posts: 300
when they sit for a while they lose there prime and it takes awhile to build the fuel pressure back up ,

when it sits for over a month the night b4 u go riding put a battery tender on it or just make sure the battery is full to...

battery will go dead quick if ur trying to start if for a lil bit , after a battery has sat for a while to ..

2007 660 SE - DUAL MUZZY - K&N SET UP - INNOVATE WIDEBAND TUNED - RUGGED RACE RADIO - GEAR ONE RACK -

http://performancetruckproducts.com/

http://www.unleashedutv.com/

http://traillogicllc.com/
Benzito is offline  
post #3 of 4 (permalink) Old 06-11-2010, 05:06 AM
RhinoTalk.net Site Sponsor
 
Bryan M's Avatar
 
Join Date: Jun 2008
Location: ummmmmm Im not sure..fuck, I think were lost!
Posts: 1,377
as frank said battery tend it....or bring a jumper box with you...also add sta-bil or another brand of fuel preserver if your letting it sit for a coupla weeks at a time....its amazing how some gas lasts and some goes bad in less than a month

If you live in Vegas and need a General Contractor...call Manning Construction @ 497-5127
Bryan M is offline  
 
post #4 of 4 (permalink) Old 06-13-2010, 05:26 AM Thread Starter
1/4 Throttle
 
Join Date: Jan 2010
Posts: 5
Thanks guys!
droptine is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57