Low power?? - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-03-2010, 04:30 PM Thread Starter
JMS
Wide F'n Open
 
JMS's Avatar
 
Join Date: Jun 2008
Location: Hemet, CA
Posts: 170
Low power??

I have an 07 660 that seems to be very low powered. I bought it used and it has 1900 miles on it. It is a bit heavy as it has long travel, 4 seat cage, seats etc. I'm running 26x9x12 front and 26x11x12 rears. I know those are a bit heavy too. I just feel as if there is something wrong with the motor. I also have done the CDI, UTV Crap sheeve and purple spring, (can't remember the weights on the rollers). I have no bottom end even by myself it's all I can do to go up a hill especially in the dunes. It will do 50 MPH on flat to down hill grades but the second I hit a little hill it's as though a parachute has been thrown out. This is nothing new but I'm tired of it and need some help. Any suggestions on what to look for? Oil is good, new plug, Uni filter is clean, new belt, new fuel filter. I'm out of ideas, could the motor just be tired? I've seen a lot of Rhinos with a lot more miles than this. Sorry for the long post just need some advice from all you engine guys. Wish I had the $ for a Rotax or a 686 kit but not right now
Thanks for the help,
Justin
JMS is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-03-2010, 06:32 PM
Red Cup Ninja
 
shonuff's Avatar
 
Join Date: Jun 2008
Location: murrieta,ca
Posts: 3,312
the first thing I would do is put lighter rollers in it... either way it sounds like a clutch problem, not an engine problem

Fuck'em and feed'em cabbageI have found the richer your friends are.....the more they want you to suck their asses.......I guess these fools havent figured out yet I dont suck ass ~ the bigg anonymous
shonuff is offline  
post #3 of 3 (permalink) Old 08-03-2010, 10:35 PM Thread Starter
JMS
Wide F'n Open
 
JMS's Avatar
 
Join Date: Jun 2008
Location: Hemet, CA
Posts: 170
What is the prefered rollers now? Greasless or the greasers? What weight would you recommend? Like I said I'm heavy with the 4 seater long travel etc... Do you think I may have it installed wrong? This is my second sheave I've put in and did it just like it came out. I'll taske it apart and see what's going on inside. Thanks for the help.
JMS is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57