Headers Glowing Red - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-09-2010, 01:42 AM Thread Starter
3/4 Throttle
 
Reese's Avatar
 
Join Date: Dec 2008
Posts: 54
Headers Glowing Red

Just put on a new exhaust and after idling for 5 minutes the temps look good and the fan is cycling on and off and temps are running right at 180 but the first 2-3" of header coming off the head are glowing red not just a little but glowing red like metal you have welded. I never have the bed off so I assume its always been like that but wanted to confirm. I am getting no popping or flames on deceleration and it is running strong it just makes me a little nervous seeing that kind of heat.

Is this normal????
Reese is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-09-2010, 08:01 AM
1/4 Throttle
 
mtoma's Avatar
 
Join Date: Jan 2009
Posts: 23
What other mod's do you have? Did you re-jet or add a MSD (depending on what year rhino you have).
mtoma is offline  
post #3 of 4 (permalink) Old 09-09-2010, 09:27 AM
Wide F'n Open
 
dirtysidedown's Avatar
 
Join Date: Jun 2008
Location: Surprise,Az
Posts: 2,291
Aftermarket exhaust systems use thinner tubing and it is pretty normal for the pipes to glow but you do need to make corrections to your jetting/mapping to get the most out of the system and to avoid running it lean.

Hapa- ''When I checked into my motel, I said to the lady at the desk:

"I hope the porn channel in my room is disabled."

"No," she said, "it's just regular porn, you sick bastard."
dirtysidedown is offline  
 
post #4 of 4 (permalink) Old 09-10-2010, 04:19 PM
Founding Ninja
 
JoeyD23's Avatar
 
Join Date: Jun 2008
Location: Valley Center, CA (San Diego)
Posts: 4,540
JoeyD23 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57