07 660 rhino backfiring thru carb - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-09-2010, 10:50 AM Thread Starter
1/4 Throttle
 
Join Date: Oct 2010
Posts: 3
07 660 rhino backfiring thru carb

I have a 07 660 rhino with aftermarket cdi box and clutch sheave,everything else is stock. It will miss and backfire through the carb at low rpm's. I have recently changed the plug and it was black, also it smells like it is running rich. Any suggestions.
scottdawes is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-19-2010, 08:43 PM
1/4 Throttle
 
Join Date: Oct 2010
Location: Elwood IL
Posts: 6
mine did the same thing until i rejetted the carb. i have stock exaust but i do have a air filter and cdi. the stock jet is a 145 and i went with a 150, it worked for me and it might work for you. also check your fuel filter and make shure its clean.

2005 Rhino 660
Big Gun cdi
Dyno jet kit
Uni air filter
Trail tec Vapor computer
Custom dash
huterworks overdrive clutch weights
4 150 watt KC daylighters
extra battery
55+ mph
SteveSmith is offline  
post #3 of 4 (permalink) Old 10-22-2010, 12:42 PM
Founding Ninja
 
Unleashed UTV's Avatar
 
Join Date: Jun 2008
Posts: 691
Quote:
Originally Posted by scottdawes View Post
I have a 07 660 rhino with aftermarket cdi box and clutch sheave,everything else is stock. It will miss and backfire through the carb at low rpm's. I have recently changed the plug and it was black, also it smells like it is running rich. Any suggestions.
Sounds like jetting, but it could be valve adjustment. They tighten up as they ware and need to be adjusted to have some clearance.

Unleashed UTV
5838 N. 19th Ave
Phoenix, AZ 85015
602-246-4011
www.unleashedutv.com
Unleashed UTV is offline  
 
post #4 of 4 (permalink) Old 05-11-2011, 06:12 AM
1/4 Throttle
 
Join Date: Sep 2009
Posts: 11
mine was doing the same thing. after much research I found a small hole in the main diaphram on top of the carb. I had to use a led light and a lot of stretching of it to find it but I replaced the diaphram and that fixed it
yamadog is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57