Brakes Squeaking bad.... - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-04-2011, 05:19 PM Thread Starter
1/4 Throttle
 
Join Date: Jan 2011
Posts: 1
Angry Brakes Squeaking bad....

I purchased a used 2004 660 Rhino and the brakes have squeaked from the day I bought it. I went to a local dealer and they told me that Yamaha had come out with some new pads that solved this problem. I bought new sets for the entire rhino and installed them. This took away the squeak for about a week and then it started again. I have also tried the red brake backer gunk and grease on the back of the pads like 2 dealers have suggested. Still the brakes squeak terrible. I am so frustrated that I am about to sell the unit and buy another brand.

I can't believe I own the only Rhino with this problem and my 2 local dealers cannot come up with a solution. I am certainly not a brake mechanic but cannot believe I should have to ride listening to this horrible chirpping.

Has anyone out there had squeaky brakes and what did you do to silence them?

Desperate and frustrated in Michigan....
Fred6949 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-05-2011, 05:23 PM
1/4 Throttle
 
mtoma's Avatar
 
Join Date: Jan 2009
Posts: 23
Welcome to the world of owning a rhino or any offroad UTV/ATV for that matter. They all squeek after running them through dirt, mud, water, snow, etc.
I put a set of EBC severe duty brake pads on my 08 and that seemed to help alot. Now the only squeeking I still have is from the e-brake.
Your 04 has 1 rear disc that handles both the rear braking and e-brake duties so you should be fine as long as you replace it also.
mtoma is offline  
post #3 of 3 (permalink) Old 04-09-2015, 06:02 AM
1/4 Throttle
 
Join Date: Mar 2012
Location: ohio
Posts: 10
If i am understanding on this noise issue, where I am hearing that never ending noise is from the drive shaft E-brake. that has a pad or it just clamps to the disk? mine is a 07 450.
any cures to eliminate it, usually when you take off slow it squeaks and squeaks .
ronaround is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57