660 idles fine but no power - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-10-2011, 02:12 PM Thread Starter
1/4 Throttle
 
BERZERK's Avatar
 
Join Date: Jul 2011
Posts: 2
660 idles fine but no power

I have an 06 660 that ran great till yesterday when crossing a log came down hard on floor pan. And now cuts out and backfires, sometimes thru carb when i press on the throttle. Any suggestions, am not a retard but not a rhino mechanic thanks
BERZERK is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-17-2011, 07:03 PM
1/4 Throttle
 
Join Date: Jul 2011
Location: Down South
Posts: 2
Hey berzerk...My rhino started backfiring on a ride and got worse over the course of a few miles. Now, the rhino will idle but cuts out on first 1/4 of throttle....sputters and backfires through breather box...... I have replaced fuel, fuel filter,spark plug, checked/cleaned jets in carb twice. I have still not found a solution....I guess I could check valves next. Not sure...everything is stock on my 660 except for BR CDI. I am still looking for a solution as well...any advice anyone?

Last edited by Lamont3c; 07-17-2011 at 08:33 PM.
Lamont3c is offline  
post #3 of 4 (permalink) Old 07-17-2011, 08:09 PM
1/4 Throttle
 
Join Date: Jul 2011
Location: Down South
Posts: 2
UPDATE: Backfire through carb and stall solved. I decided to check the valve throttle located under the top cover of carb and found it to be stuck. Lubricated and freed up throttle valve , put back together, and it idled and throttled perfect. Hope this helps.
Lamont3c is offline  
 
post #4 of 4 (permalink) Old 07-18-2011, 10:15 PM Thread Starter
1/4 Throttle
 
BERZERK's Avatar
 
Join Date: Jul 2011
Posts: 2
Thanks so much will try that this weekend
BERZERK is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57