no top end - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-15-2011, 08:37 AM Thread Starter
1/4 Throttle
 
Join Date: Sep 2009
Posts: 11
no top end

My 660 rhino idles great and runs great at slow to medium speeds but, when I open it up it acts like i'm at the rev limiter at about 30 mph. What do y'all think is wrong with it?
yamadog is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-15-2011, 10:37 PM
1/4 Throttle
 
Join Date: Aug 2011
Posts: 2
My 06 660 did the exact same thing but before I got a chance to fix it my wife sold it to her sister and for her 30 is faster than she'll go. One guy suggested it might be the belt slipping but I'm not sure might not hurt to check it out though.
little bob bill is offline  
post #3 of 4 (permalink) Old 10-31-2011, 10:17 PM
3/4 Throttle
 
Reese's Avatar
 
Join Date: Dec 2008
Posts: 54
Check if reverse light is flickering when it falls on its face, mine did the same thing and I couldnt see it in daylight but at night I finnaly noticed a quick flicker on the reverse light that caused the reverse rev limiter to kick in and make it cut out. The fault was a green wire on the passenger side right under the carb that had a loose connection.

I was ready to give up after carb rebuild, fuel filter, fuel pump etc.

Check it out it could be your problem.
Reese is offline  
 
post #4 of 4 (permalink) Old 03-15-2012, 05:34 PM
1/4 Throttle
 
RAILER's Avatar
 
Join Date: Mar 2012
Posts: 2
railer

Will a performance cdi cause a rhino 06 660 to run to rich???? Would a stock cdi be better for passing emissions?? I have high co readings....should be 5.50 but i am reading 9.34...went back to stock mains and jets...and replaced the needle and seat...new plug and adjust the valves.
RAILER is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57