09' rhino not taking off until rpms are up - Yamaha Rhino Forums - Yamaha UTV Forum
Yamaha Rhino Performance Discussions Yamaha Rhino performance discussions.
Engine mods, CDI boxes, exhausts, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-29-2012, 10:40 PM Thread Starter
1/4 Throttle
 
ReddingRhino's Avatar
 
Join Date: Jan 2012
Posts: 4
09' rhino not taking off until rpms are up

Ok here it goes, new to the site, new to rhinos, owned a 04' grizzly 660 before this and never had any issues with it. Just bought the 09' rhino, it was a repo that I bought from an atv shop. It has the following mods that I know about, trinity stage IV dual full exhaust, afe cold air intake and a power commander that I installed on it. There is a EPI clutch sticker on the intake box but dont know if it has it. 1200 miles and 140 hours on the bike. 27" tires.

The Good: love the utv.

The bad: already have to work on it. probably not the utv's fault.

The help needed: went for the first ride and everything seemed ok until we stopped to go down in a dry creek bed and come up the other side. When i went to go up the other side it sounded like i was burning rubber on pavement, problem was i wasnt. Doesnt take a rocket scientist to figure out what was happening, belt slipping. So I always by stock clutches for my dirt bikes so stock belt for the rhino?

Next help: How do I determine if any sheave or cluth springs/weights have been modified and if they havent which direction should i go? Im running 27" tires and I would like this thing to move as soon as i touch the gas pedal. currently it takes probably 800 to a 1000 rpms to get it to move.

Last help needed: Anyone have a map for the power commander that would be good for the setup listed above? currently running one off of power commanders website for the dual muzzeys. Its ok but i feel it need more on the lower end.

Thanks for taking the time to read this lengthy post and any help is greatly appreciated.
ReddingRhino is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-30-2012, 07:45 AM
Enjoying my Rhino
 
Join Date: Oct 2010
Location: Mount Hope, WV
Posts: 45
call me and we will get you lined out
WV Hot Rod Rhino is offline  
post #3 of 8 (permalink) Old 01-30-2012, 07:46 AM
Enjoying my Rhino
 
Join Date: Oct 2010
Location: Mount Hope, WV
Posts: 45
304-673-2602
WV Hot Rod Rhino is offline  
 
post #4 of 8 (permalink) Old 01-30-2012, 03:41 PM Thread Starter
1/4 Throttle
 
ReddingRhino's Avatar
 
Join Date: Jan 2012
Posts: 4
Thanks James, I sent you those pics hope you got them. I went ahead and ordered a new cam for the sheave since the spline grooves were all jacked. also ordered a new belt and cam guides. The primary shaft was not harmed. What kind of turnaround time am i looking at if i send you the sheave and have you mill it?
ReddingRhino is offline  
post #5 of 8 (permalink) Old 01-30-2012, 04:51 PM
Enjoying my Rhino
 
Join Date: Oct 2010
Location: Mount Hope, WV
Posts: 45
Quote:
Originally Posted by ReddingRhino View Post
Thanks James, I sent you those pics hope you got them. I went ahead and ordered a new cam for the sheave since the spline grooves were all jacked. also ordered a new belt and cam guides. The primary shaft was not harmed. What kind of turnaround time am i looking at if i send you the sheave and have you mill it?

i have everything for the clutches in stock..camplate 25.00...oem belts 100.00
call me...seen your pics
WV Hot Rod Rhino is offline  
post #6 of 8 (permalink) Old 01-31-2012, 01:32 PM Thread Starter
1/4 Throttle
 
ReddingRhino's Avatar
 
Join Date: Jan 2012
Posts: 4
Thanks for the help James. My sheave is on its way. Probably be there by friday or saturday.

John
ReddingRhino is offline  
post #7 of 8 (permalink) Old 01-31-2012, 01:54 PM
1/4 Throttle
 
Join Date: Dec 2011
Posts: 3
You are in good hands.....James will take great care of you.
07bluelbz is offline  
post #8 of 8 (permalink) Old 01-31-2012, 05:58 PM
Enjoying my Rhino
 
Join Date: Oct 2010
Location: Mount Hope, WV
Posts: 45
thanks guys
WV Hot Rod Rhino is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forums - Yamaha UTV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57