Yamaha Rhino Forums - RhinoTalk banner
1 - 11 of 11 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
I noticed the other day my low beams are not working. I have not investigated this problem yet but about how many hrs should I get out of stock headlights. Every time my engine is running my low beams were on. High beams work fine. I have close to 180 hrs on my Rhino.
Rick.
 

·
Registered
Joined
·
155 Posts
Not sure how long the stockers last. I changed to Vision X Hids. If you go just replace the bulbs. I would suggest you get the PIAA bulbs. Much brighter than stock. Northland Motorsports in Flagstaff has them. Not sure about Outdoorsports in PV. ( I rather drive to Flagstaff, better store)
 

·
Registered
Joined
·
3,155 Posts
I noticed the other day my low beams are not working. I have not investigated this problem yet but about how many hrs should I get out of stock headlights. Every time my engine is running my low beams were on. High beams work fine. I have close to 180 hrs on my Rhino.
Rick.
Might be relay if they are both out.


Rog
 

·
Registered
Joined
·
5,383 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #8 ·
Well it seems after about 180 hrs of running with the low beams on the headlights had given up. Checked the sockets with a test light and found both sides working. Sooo I went to the dealer and got bent over for 22.00 for two headlights. :mad:
Rick.
 

·
Registered
Joined
·
3,087 Posts
Well it seems after about 180 hrs of running with the low beams on the headlights had given up. Checked the sockets with a test light and found both sides working. Sooo I went to the dealer and got bent over for 22.00 for two headlights. :mad:
Rick.
Ouch!!! did they at least shake ur hand after they F'd ya? oh well, its fixed!
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top